Version 2.0

geschrieben von Henning.Meyer 
Willkommen! Anmelden Ein neues Profil erzeugen Suche
Version 2.0
10. Oktober 2015 15:34
Hallo,

wann können wir die neueste Version 2.0 testen? Der Alpha-Link auf Sourceforge geht leider nicht und sicherlich ist inzwischen einiges passsiert. Wenn Ihr Hilfe braucht, sagt einfach Bescheid...

Wird Jira aktuell noch gepflegt?

Danke für die Rückinfo

Henning Meyer
Re: Version 2.0
10. Oktober 2015 16:29
Hallo Henning,
der Link auf Sourceforge lautet [sourceforge.net]
JIRA ist aktuell, es wird bloß gerade nicht viel an den Tickets gearbeitet, weil es keine Kapazitäten gibt. Es gibt aber eine neue Alpha-Version. Steht auch im Blog.

Viele Grüße,
Ralf.
Re: Version 2.0
10. Oktober 2015 17:11
Hi,

ich habe sie kurz nach dem Thread schon gefunden und getestet, sorry. Ich lief beim Konvertieren der Kontakte auf folgenden Fehler:

!!! error while migrating Contact. (old) ID=0; Reason: Exception [EclipseLink-4002] (Eclipse Persistence Services - 2.6.0.v20150309-bf26070): org.eclipse.persistence.exceptions.DatabaseException
Internal Exception: java.sql.SQLSyntaxErrorException: user lacks privilege or object not found: FKT_CATEGORY
Error Code: -5501
Call: SELECT ID, categoryName, DATEADDED, DELETED, MODIFIED, MODIFIEDBY, NAME, ABSTRACTCATEGORY_PARENT FROM FKT_CATEGORY WHERE ((NAME = ?) AND (categoryName = ?))
bind => [2 parameters bound]
Query: ReadAllQuery(referenceClass=ContactCategory sql="SELECT ID, categoryName, DATEADDED, DELETED, MODIFIED, MODIFIEDBY, NAME, ABSTRACTCATEGORY_PARENT FROM FKT_CATEGORY WHERE ((NAME = ?) AND (categoryName = ?))"winking smiley
!!! error while migrating Contact. (old) ID=1; Reason: Exception [EclipseLink-4002] (Eclipse Persistence Services - 2.6.0.v20150309-bf26070): org.eclipse.persistence.exceptions.DatabaseException
Internal Exception: java.sql.SQLSyntaxErrorException: user lacks privilege or object not found: FKT_CATEGORY
Error Code: -5501
Call: SELECT ID, categoryName, DATEADDED, DELETED, MODIFIED, MODIFIEDBY, NAME, ABSTRACTCATEGORY_PARENT FROM FKT_CATEGORY WHERE ((NAME = ?) AND (categoryName = ?))
bind => [2 parameters bound]

Leider schiesst er dabei die Datenbank ab und will das Programm anschließend gar nicht mehr starten.

Mein System: Microsoft Server 2012 R2 mit Java 64-Bit und Fakturama 64-Bit.

PS: Der Splash-Screen zeigt beim Starten Fakturama 1.6.1 an?

Danke im Voraus

Henning
Re: Version 2.0
11. Oktober 2015 01:03
Hallo Henning,
danke für die Rückmeldung. Ich muß wahrscheinlich gleich nochmal ein neues Alpha-Release bauen, offenbar hat es einige Tabellen nicht angelegt. Der Fehler tritt ja bereits beim ersten Datensatz auf.

Das mit dem Splash-Screen ist ok, ich hab den einfach noch nicht geändert. Außerdem soll mich das daran erinnern, die Änderungen seit der 1.6.1 noch nachzuziehen (das war der Stand, ab dem ich Fakturama 2.0 angefangen habe).

Viele Grüße,
Ralf.
Re: Version 2.0
13. Oktober 2015 01:04
Hallo Ralf,

soeben wollte ich die 2er Version vom 7.10.15 mal testen.
Bei der Installation kommen aber bereits fehlende Abhängigkeiten.

Mein System: KUBUNTU 15.04 AMD64 aktuell
Auf diesem System war Fakturama noch nie installiert.

Viele Grüße
Hans
Re: Version 2.0
13. Oktober 2015 20:43
Hallo Hans, hast Du das aktuelle Java installiert? Das wird nämlich vorausgesetzt (Java 8).

Viele Grüße,
Ralf.
Re: Version 2.0
14. Oktober 2015 18:36
Hallo Ralf,

ja, das habe ich.
Ich habe noch mal abgefragt, ob auch die Oracle Java 8 aktiv ist - und sie ist es.

Viele Grüße
Hans
Re: Version 2.0
14. Oktober 2015 19:09
Hm. Komisch. Kannst Du mir bitte mal die Fehlermeldung schicken?

Viele Grüße,
Ralf.
Re: Version 2.0
14. Oktober 2015 19:47
Nur:
"Status: Fehler: Abhängigkeiten können nicht erfüllt werden."

Oder finde ich in einer Log.Datei (Wo=?) noch was genaueres?

Viele Grüße
Hans
Re: Version 2.0
14. Oktober 2015 23:36
Sieht irgendwie nach Linux-Meldung aus. Logfile findest Du unter ~\.fakturama2\.metadata\.log. Schau mal bitte nach, ob da was drinsteht.

Viele Grüße,
Ralf.
Re: Version 2.0
15. Oktober 2015 09:05
Ja, das ist eine Meldung von Linux, jedoch vor Start der Installation.
Linux prüft erst ab und installiert nur dann, wenn die Voraussetzungen o.k. sind.
Deswegen gibt es auch den fakturama2-Ordner und den log-File noch nicht.
Leider ist dort nicht aufgeführt, was die Installation vermisst.
Kann das evt. im Zusammenhang mit fehlenden Dateien zu Eclipse stehen?
Hast Du eine Liste, welche Dateien/Pakete Fakturame2 benötigt?
Wie gesagt auf dem System war Fakturama noch nie drauf!

Viele Grüße
Hans
Re: Version 2.0
15. Oktober 2015 18:11
Hm. Das Installationspaket bringt eigentlich sämtliche Abhängigkeiten mit, die Fakturama selber benötigt. Ob das vielleicht die (optionale) Abhängigkeit zu LibreOffice ist? Ist das installiert?

Viele Grüße,
Ralf.
Re: Version 2.0
15. Oktober 2015 18:48
LibreOffice 5.0.2 ist installiert, dürfte doch aber kaum eine Abhängigkeit darstellen.
Die vohergehende Alpha-Version war noch installierbar, lief aber nicht.

Viele Grüße
Hans
Re: Version 2.0
15. Oktober 2015 20:25
Hast Du versucht, das deb-Paket zu installieren? Meines Wissens gibt es irgendeine Option, mit der man herausbekommen kann, von was das Paket abhängt. Ich habe zumindest nur java8-jdk | java8-runtime | java8-sdk angegeben.

Viele Grüße,
Ralf.
Re: Version 2.0
16. Oktober 2015 01:37
Java ist alles vorhanden, also kein Problem.
Um die Abhängigkeiten herauszubekommen habe ich Aptitude installiert,
welches mir seltsamerweise sagt, dass das Paket nicht vorhanden ist.
-----------------------------------------
$ sudo aptitude show Fakturama_linux_64Bit_2_0_0-20151007.deb
[100%] Abhängigkeitsbaum wird aufgebaut.
[100%] Lesen der erweiterten Statusinformationen
[ 0%] Initialisieren des Paketstatus'
[ 0%] Schlagwortdatenbank wird erstellt
E: Das Paket Fakturama_linux_64Bit_2_0_0-20151007.deb konnte nicht gefunden werden.
$
(Bei den %en bin ich mir nicht sicher, es geht zu schnell und den log-file kenne ich nicht)
-----------------------------------------
Mit apt-get sieht es ähnlich aus:
-----------------------------------------
$ sudo apt-get install Fakturama_linux_64Bit_2_0_0-20151007.deb
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
E: Paket Fakturama_linux_64Bit_2_0_0-20151007.deb kann nicht gefunden werden.
E: Mittels regulärem Ausdruck »Fakturama_linux_64Bit_2_0_0-20151007.deb« konnte kein Paket gefunden werden.
$
-----------------------------------------
Ich habe wirklich 10x hingeschaut, dass ich keinen Fehler mache.
Es sieht so aus, als ob sich das Paket bei der Installation "selber nicht finden kann".
Vielleicht hilft das weiter?
Kann es sein, dass irgend ein Verweis falsch ist?

Viele Grüße
Hans
Re: Version 2.0
16. Oktober 2015 17:36
Hi

was sagt


sudo dpkg -i /path/to/Fakturama_linux_64Bit_2_0_0-20151007.deb


aptitude und apt-get sucht das packet in den Repositories die in den Konfigs angegeben sind.
Dort gibt es das aber nicht.

lg Chris
Re: Version 2.0
16. Oktober 2015 19:50
Oh je, danke Chris. Wieder was gelernt. Ich nahm an, dass es bei Angabe des Paketes funktioniert.

Habe jetzt mit dpkg installiert, was erst mal funktionierte. Nach der Übernahme der alten Daten starte ich Fakturama neu und bekomme eine Fehlermeldung -> siehe log-File.
Dann habe ich nochmals gestartet und die Konvertierung lief, bis wieder Fehler -> siehe log-File.

Übrigens sonst installiere ich mit QApt-Paketinstallationsprogramm und da kam eben die Fehlermeldung "Abhängigkeiten können nicht erfüllt werden" (Nur welche = ?).

Wie kann ich Dir, Ralf den log-File zuspielen? (Wäre etwas lang zum hierher kopieren.)

Viele Grüße
Hans
Re: Version 2.0
16. Oktober 2015 23:36
Schick mir das bitte mal an meine E-Mail-Adresse (siehe Impressum). Ich hatte übrigens auch Probleme, das DEB zu installieren, aber auf die von ckvsoft vorgeschlagene Weise bin ich auch nicht gekommen (bin halt kein Linuxer ;-) ). Ich hab's anderweitig hinbekommen.

Viele Grüße,
Ralf.
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen