macOS Sierra Fakturama lässt sich nicht öffnen

geschrieben von sebastian361 
Willkommen! Anmelden Ein neues Profil erzeugen Suche
macOS Sierra Fakturama lässt sich nicht öffnen
05. Dezember 2016 18:59
Hallo zusammen,

ich habe mir heute Fakturama runtergeladen und installiert (Java 6 und Lieber office auch), wenn ich jetzt Fakturama öffnen will kommt folgende Meldung:


The Fakturama executable launcher was unable to locate its
companion shared library.

und das Programm lässt sich nicht öffnen.

Habe ich etwas grundlegendes vergessen zu installieren?

Für Hilfestellungen und Tipps bin ich sehr dankbar.

Viele Grüße

Sebastian
Re: macOS Sierra Fakturama lässt sich nicht öffnen
05. Dezember 2016 21:48
Zunächst mal geht Fakturama nur noch ab Java Version 7. Dann gibt es auch noch einen Workaround, der auf der Downloadseite verlinkt ist. Hast Du den mal ausprobiert?

Viele Grüße,
Ralf.
Re: macOS Sierra Fakturama lässt sich nicht öffnen
08. Dezember 2016 17:11
ggf. installierst du einmal die alte Java6 für macOS siehe link


MacOS java
Re: macOS Sierra Fakturama lässt sich nicht öffnen
14. Dezember 2016 22:10
Hallo Ralf, Hallo grn00m,

danke für die Tipps, ich werde es die Tage nochmal probieren.

Wenn es läuft melde ich mich wieder.

Schönen Abend
Re: macOS Sierra Fakturama lässt sich nicht öffnen
20. Dezember 2016 21:32
Hallo sebastian361,
es befindet sich ein Fehler in dem Workaround, beziehungsweise funktioniert er unter Sierra nicht. Um Fakturama unter Sierra zum laufen zu bringen, musst du vor den beiden "plugins"-Foldern die Punkte und Slashes entfernen. Danach startet Fakturama wieder.
Anbei mal meine fakturama.ini die funktioniert.

-startup
plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
-vm
/Library/Java/JavaVirtualMachines/jdk1.8.0_112.jdk/Contents/MacOS/libjli.dylib
--launcher.library
plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.101.v20120109-1504
-vmargs
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
-Xdock:name=Fakturama
Re: macOS Sierra Fakturama lässt sich nicht öffnen
25. Dezember 2016 10:10
Hallo alle

Ich habe das gleiche Problem, das löschen der Punke und Slashes wie von dtoenies hat geholfen.

Bin somit einen Schritt weiter :-)

Jetzt kommt jedoch eine weitere Fehlermeldung beim Laden der Software.

Hat evtl. jmd eine Lösung dazu? Wäre sehr dankbar!

Hier die Logdatei dazu:

!SESSION 2016-12-24 18:25:01.088 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_65
java.vendor=Apple Inc.
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=de_CH
Framework arguments:  -keyring /Users/ea_usr/.eclipse_keyring -showlocation
Command-line arguments:  -os macosx -ws cocoa -arch x86_64 -keyring /Users/ea_usr/.eclipse_keyring -showlocation

!ENTRY org.eclipse.osgi 2 0 2016-12-24 18:25:02.268
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-12-24 18:25:02.268
!MESSAGE Bundle com.sebulli.fakturama_1.6.9 [5] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2016-12-24 18:25:02.268
!MESSAGE Bundle com.sebulli.fakturama.help_1.6.9 [6] was not resolved.

!ENTRY org.eclipse.osgi 4 0 2016-12-24 18:25:02.277
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application "com.sebulli.fakturama.application" could not be found in the registry. The applications available are: org.eclipse.equinox.app.error, org.eclipse.equinox.p2.director, org.eclipse.equinox.p2.garbagecollector.application, org.eclipse.equinox.p2.publisher.InstallPublisher, org.eclipse.equinox.p2.publisher.EclipseGenerator, org.eclipse.equinox.p2.publisher.ProductPublisher, org.eclipse.equinox.p2.publisher.FeaturesAndBundlesPublisher, org.eclipse.equinox.p2.reconciler.application, org.eclipse.equinox.p2.repository.repo2runnable, org.eclipse.equinox.p2.repository.metadataverifier, org.eclipse.equinox.p2.artifact.repository.mirrorApplication, org.eclipse.equinox.p2.metadata.repository.mirrorApplication, org.eclipse.equinox.p2.updatesite.UpdateSitePublisher, org.eclipse.equinox.p2.publisher.UpdateSitePublisher, org.eclipse.equinox.p2.publisher.CategoryPublisher, org.eclipse.help.base.infocenterApplication, org.eclipse.help.base.helpApplication, org.eclipse.help.base.indexTool.
	at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:248)
	at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
Re: macOS Sierra Fakturama lässt sich nicht öffnen
25. Dezember 2016 22:11
Hallo Ramboni,
die Java-Version geht nicht:

Zitat

java.version=1.6.0_65

Du mußt mindestens Version 7 installieren.

Viele Grüße,
Ralf.
Re: macOS Sierra Fakturama lässt sich nicht öffnen
31. Dezember 2016 15:16
Hallo,
ich stehe seit Stunden vor dem selben Problem. Trotz Java 8 installation behauptet die Log es sei Java 1.6 installiert. Hier der Auszug.

!SESSION 2016-12-31 15:10:27.505 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_65
java.vendor=Apple Inc.
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=de_DE
Framework arguments: -vm/ Library/Java/JavaVirtualMachines/jdk1.8.0_111.jdk/Contents/MacOS/libjli.dylib -keyring /Users/junesbadrian/.eclipse_keyring -showlocation
Command-line arguments: -os macosx -ws cocoa -arch x86_64 -vm/ Library/Java/JavaVirtualMachines/jdk1.8.0_111.jdk/Contents/MacOS/libjli.dylib -keyring /Users/junesbadrian/.eclipse_keyring -showlocation


Ich hab X Varianten geprüft und gestetet. Java 1.7 installation. Java 8 - Nur wenn Java 6 installiert ist komme ich einen Schritt weiter. Fakturama läd und die Fehlermeldung mit der Log Datei kommt. Das ist echt grausam. Vielleicht hat jemand mittlerweile eine Lösung.
Vielen Dank und guten Rutsch.
Junes
Re: macOS Sierra Fakturama lässt sich nicht öffnen
31. Dezember 2016 18:06
Hi Junes,
ich hatte das gleiche Problem, nur nicht mit deiner OS Version...

Siehe Forumseintrag von gestern(hier der letzte Eintrag eingefügt)


So, geschafft --> Anwendung läuft thumbs up

Habe das neuste Java installiert...
1.8.0_112, x86_64: "Java SE 8" /Library/Java/JavaVirtualMachines/jdk1.8.0_112.jdk/Contents/Home

und die INI-Datei so hinterlegt.
-startup
plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
-vm
/Library/Java/JavaVirtualMachines/jdk1.8.0_112.jdk/Contents/Home/jre/lib/jli/libjli.dylib
--launcher.library
plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.101.v20120109-1504
-vmargs
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
-Xdock:name=Fakturama

Vielleicht war die Kombination der richtige Weg zum Erfolg.
Nun, ich mache nun mal meine ersten "Gehversuche" im Programm und bin schon sehr gespannt.

Viele Grüße an das Forum und einen guten Rutsch ins Jahr 2017

Richard
Antworten Zitieren

Viel Erfolg und Grüße
Richard
Re: macOS Sierra Fakturama lässt sich nicht öffnen
01. Januar 2017 14:07
Hallo,

ich habe alle Hürden überwunden (Java 6 & 8) installiert und die .ini angepasst. Nun kommt folgende Meldung:

The Fakturama executable launcher was unable to locate its
companion shared library.


An was kann dies noch liegen?

Viele Grüsse aus dem neuen Jahr!
Martin
KRW
Re: macOS Sierra Fakturama lässt sich nicht öffnen
04. Januar 2017 21:55
Guten Abend allerseits,
ich doktor jetzt auch schon den halben Abend an der .ini Datei herum, jetzt bin ich schon etwas weiter, das Programm startet, aber dann kommt eine Fehlermeldung, Logfile sieht so aus:

!SESSION 2017-01-04 21:08:40.610 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_65
java.vendor=Apple Inc.
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=de_DE
Framework arguments: -keyring /Users/knuthweidemann/.eclipse_keyring -showlocation
Command-line arguments: -os macosx -ws cocoa -arch x86_64 -keyring /Users/knuthweidemann/.eclipse_keyring -showlocation

!ENTRY org.eclipse.osgi 2 0 2017-01-04 21:08:45.026
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-01-04 21:08:45.026
!MESSAGE Bundle com.sebulli.fakturama_1.6.9 [5] was not resolved.
!SUBENTRY 2 com.sebulli.fakturama 2 0 2017-01-04 21:08:45.026
!MESSAGE Missing Constraint: Bundle-RequiredExecutionEnvironment: JavaSE-1.7
!SUBENTRY 1 org.eclipse.osgi 2 0 2017-01-04 21:08:45.026
!MESSAGE Bundle com.sebulli.fakturama.help_1.6.9 [6] was not resolved.
!SUBENTRY 2 com.sebulli.fakturama.help 2 0 2017-01-04 21:08:45.026
!MESSAGE Missing Constraint: Bundle-RequiredExecutionEnvironment: JavaSE-1.7

!ENTRY org.eclipse.osgi 4 0 2017-01-04 21:08:45.029
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application "com.sebulli.fakturama.application" could not be found in the registry. The applications available are: org.eclipse.equinox.app.error, org.eclipse.equinox.p2.director, org.eclipse.equinox.p2.garbagecollector.application, org.eclipse.equinox.p2.publisher.InstallPublisher, org.eclipse.equinox.p2.publisher.EclipseGenerator, org.eclipse.equinox.p2.publisher.ProductPublisher, org.eclipse.equinox.p2.publisher.FeaturesAndBundlesPublisher, org.eclipse.equinox.p2.reconciler.application, org.eclipse.equinox.p2.repository.repo2runnable, org.eclipse.equinox.p2.repository.metadataverifier, org.eclipse.equinox.p2.artifact.repository.mirrorApplication, org.eclipse.equinox.p2.metadata.repository.mirrorApplication, org.eclipse.equinox.p2.updatesite.UpdateSitePublisher, org.eclipse.equinox.p2.publisher.UpdateSitePublisher, org.eclipse.equinox.p2.publisher.CategoryPublisher, org.eclipse.help.base.infocenterApplication, org.eclipse.help.base.helpApplication, org.eclipse.help.base.indexTool.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:248)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)

Für einen heißen Tipp wäre ich ausserordentlich dankbar!

Gruss
Knuth
Re: macOS Sierra Fakturama lässt sich nicht öffnen
05. Januar 2017 14:14
Hallo Knuth,

mein Tipp: es liegt an der Java Version.
Zitat

java.version=1.6.0_65
Warum hast du 2 Versionen installiert? Sag deinem System mal, dass es Version 8 nehmen soll.

Gruß
moped
Re: macOS Sierra Fakturama lässt sich nicht öffnen
05. Januar 2017 22:20
Hallo zusammen,

ich habe alles deinstalliert Java 1.6 & 1.8, sowie Fakturama. Dann nur noch Java 1.8.x installiert die Fakturama.ini angepasst und Fakturama gestartet. Dann kam wieder die Meldung man müsse Java 1.6 installieren. Per Zufall habe ich im Finder dann auf das Fakturama (exe) geklickt und siehe da, das Programm läuft !!!
Eigentlich steht es in der Umgehungslösung ...

Gruss Martin
Re: macOS Sierra Fakturama lässt sich nicht öffnen
15. Januar 2017 12:55
Hallo Leute,

ich werde momentan komplett wahnsinnig... Ich bin erst neu auf Mac umgestiegen und musste mir jetzt eine neue Fakturierungssoftware suchen.

Leider lässt sich Fakturama bei mir einfach nicht öffnen...
Ich habe die .ini Datei so angepasst wie es hier schon öfters beschrieben ist. Auch Java Version 1.8.111 ist installiert.
Leider sagt mir das Programm jedes Mal, dass ich doch bitte Java Version 6 installieren soll, auch wenn ich über die Datei im Applications Ordner gehe. Sobald ich das aber mache, will Fakturama auf diese alte Version zugreifen, statt Version 8 zu benutzen. Ich komme einfach nicht mehr weiter, ich hoffe mir kann jemand helfen...

Bildschirmfoto:

Vielen Dank & Grüße
Tobias
Re: macOS Sierra Fakturama lässt sich nicht öffnen
15. Januar 2017 14:51
Re: macOS Sierra Fakturama lässt sich nicht öffnen
15. Januar 2017 18:14
Hallo Martin,

erst einmal vielen Dank für deine schnelle Hilfe.

Allerdings bin ich leider noch nicht viel weitergekommen...
Ich starte Fakturama bereits über den Installationsordner. Dabei wird das Terminal geöffnet und danach kommt die Meldung mit der alten Java Version.

Hier mal meine .ini Datei:

-startup
plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
-vm
/Library/Java/JavaVirtualMachines/jdk1.8.0_111.jdk/Contents/Home/
--launcher.library
plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.101.v20120109-1504
-vmargs
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
-Xdock:name=Fakturama

Hab ich da was vergessen oder übersehen?

Vielen Dank & viele Grüße
Tobias
Re: macOS Sierra Fakturama lässt sich nicht öffnen
15. Januar 2017 19:20
Häng mal jre/lib/jli/libjli.dylib nach .../Home/ an.
Re: macOS Sierra Fakturama lässt sich nicht öffnen
15. Januar 2017 20:21
Jetzt funktioniert es einwandfrei :-).

Super, vielen Dank für die Hilfe!!
Re: macOS Sierra Fakturama lässt sich nicht öffnen
10. November 2017 08:00
Weiß nicht ob das Thema vielleicht bereits veraltet ist, gilt aber auch für High Sierra. Anbei meine .ini-Datei, die zumindest bei mir funktioniert.
-startup
plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
-vm
/Library/Java/JavaVirtualMachines/jdk1.8.0_111.jdk/Contents/MacOS/libjli.dylib
--launcher.library
plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.101.v20120109-1504
-vmargs
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
Re: macOS Sierra Fakturama lässt sich nicht öffnen
14. Dezember 2017 19:48
Wo finde ich diese .ini Datei im Apfeldschungel?
Re: macOS Sierra Fakturama lässt sich nicht öffnen
16. Dezember 2017 20:23
/Applications/Fakturama.app/Contents/Eclipse/Fakturama.ini

Viele Grüße,
Ralf.
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen