Installation

geschrieben von mooev 
Willkommen! Anmelden Ein neues Profil erzeugen Suche
Installation
21. August 2019 15:26
Hallo, ich werde verrückt.

Version Mac OS 10.14.6 (18G87), Java V 8 Update 221 (1.8.0_221-b11).

Java bereits einmal komplett deinstalliert und neu installiert.

Kann Fakturama2 nicht öffnen.

Log:

!SESSION Wed Aug 21 14:14:55 GMT+01:00 2019 ------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2019-08-21 14:14:55.411
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.UnsupportedClassVersionError: org/eclipse/core/runtime/adaptor/EclipseStarter : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:650)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
at org.eclipse.equinox.launcher.Main.run(Main.java:1499)


WAS BITTE MACHE ICH FALSCH? Ich versteh es nicht.

Danke für Eure Hilfe!!!

LG David



1-mal bearbeitet. Zuletzt am 22.08.19 11:54.
Re: Installation Mac OS 10.14.6 (18G87)
22. August 2019 10:35
...und hier noch einmal die INI:

-startup
../Eclipse/plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
-vm
../Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
--launcher.library
../Eclipse/plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.551.v20171108-1834
-vmargs
-DREFRESH_BUNDLES=false
-Dorg.eclipse.e4.ui.css.dynamic=true
--add-modules=ALL-SYSTEM
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
-Xdock:name=Fakturama
-Xdock:icon=../Resources/app.icns

Ich habe den Library- Pfad hinzugefügt, und jetzt bekomm ich die Meldung "no java virtual machine was found after searching the following locations".

Versteht Ihr das? Warum bekomm ich Faktzrama2 nicht zum laufen?
Re: Installation
26. August 2019 20:28
Ich kann es leider ebenfalls nicht installieren bzw. öffnen confused smiley

Ich habe leider kein Wissen, was da im Hintergrund der Software passiert. Vielleicht weiß ja jemand, wie man Abhilfe schaffen könnte.
Re: Installation
27. August 2019 11:20
Ich "versuche" schon seit etwas mehr als ein halbes Jahr Fakturama unter macOS zum laufen zu bewegen, ist ein Gedulds- und Glücksspiel.

Entweder startet es und wenn man es schliesst nicht mehr, dann startet es und beim nächsten mal meckert es Java wäre in der falschen Version installiert oder wenn es denn mal startet dauert es ewig (bis zu zehn Minuten!) bis man überhaupt mal etwas machen kann, dann fehlen die Pfade zu Libre, obwohl vorher noch ein Dokument bearbeitet/erstellt wurde etc.pp.

Grundsätzlich: habs aufgegeben und nutze es nur noch als "Bastel- und Freizeitobjekt", obwohl es, wenn es denn mal funktioniert, für ein kostenloses Programm, meiner Meinung nach, wirklich ganz oben mitspielt!



1-mal bearbeitet. Zuletzt am 27.08.19 11:21.
Re: Installation Mac OS 10.14.6 (18G87)
28. August 2019 08:08
@mooev: Du hast den Pfad zu Java 6 eingetragen. Es muß aber Java 8 verwendet werden.

Viele Grüße,
Ralf.
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen