Fehler nach Installation

geschrieben von Tintenmann 
Willkommen! Anmelden Ein neues Profil erzeugen Suche
Fehler nach Installation
03. Juli 2019 00:48
Hallo und guten Tag zusammen!

Hallo,

auf der Suche nach einem Rechnungsprogramm bin ich über Fakturama 'gestolpert' und habe es installiert. Leider kommt beim ersten Start nur ein Fehler:

Ein Fehler ist aufgetreten. Informationen hierzu ....


Inhalt der ausgewiesenen .log - Datei, deren Inhalt ich leider nicht zu deuten wieß :

!SESSION 2019-07-03 00:22:20.494 -----------------------------------------------
eclipse.buildId=2.0.4.
java.version=11.0.2
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=de_DE
Command-line arguments: -os win32 -ws win32 -arch x86_64

!ENTRY org.eclipse.osgi.compatibility.state.nl_it 2 0 2019-07-03 00:22:24.815
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_it [9]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_uk 2 0 2019-07-03 00:22:24.820
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_uk [14]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_tr 2 0 2019-07-03 00:22:24.821
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_tr [13]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_ar 2 0 2019-07-03 00:22:24.823
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_ar [2]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_es 2 0 2019-07-03 00:22:24.824
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_es [5]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_el 2 0 2019-07-03 00:22:24.825
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_el [4]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_ro 2 0 2019-07-03 00:22:24.827
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_ro [11]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_hu 2 0 2019-07-03 00:22:24.828
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_hu [8]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_ru 2 0 2019-07-03 00:22:24.829
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_ru [12]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_de 2 0 2019-07-03 00:22:24.833
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_de [3]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_fr 2 0 2019-07-03 00:22:24.834
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_fr [7]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_eu 2 0 2019-07-03 00:22:24.837
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_eu [6]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_pl 2 0 2019-07-03 00:22:24.839
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_pl [10]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi 4 0 2019-07-03 00:22:24.841
!MESSAGE Anwendungsfehler
!STACK 1
org.eclipse.e4.core.di.InjectionException: java.lang.NoClassDefFoundError: javax/annotation/PostConstruct
at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:410)
at org.eclipse.e4.core.internal.di.InjectorImpl.make(InjectorImpl.java:318)
at org.eclipse.e4.core.contexts.ContextInjectionFactory.make(ContextInjectionFactory.java:162)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createDefaultHeadlessContext(E4Application.java:491)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createDefaultContext(E4Application.java:505)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createE4Workbench(E4Application.java:204)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.start(E4Application.java:149)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.base/java.lang.reflect.Method.invoke(Method.java:566)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
at org.eclipse.equinox.launcher.Main.run(Main.java:1499)
Caused by: java.lang.NoClassDefFoundError: javax/annotation/PostConstruct
at org.eclipse.e4.core.internal.di.InjectorImpl.inject(InjectorImpl.java:124)
at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:399)
... 18 more
Caused by: java.lang.ClassNotFoundException: javax.annotation.PostConstruct cannot be found by org.eclipse.e4.core.di_1.6.100.v20170421-1418
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:433)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:395)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:387)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:150)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
... 20 more

!ENTRY org.eclipse.e4.ui.workbench 4 0 2019-07-03 00:22:24.859
!MESSAGE FrameworkEvent ERROR
!STACK 0
java.lang.NoClassDefFoundError: javax/annotation/PreDestroy
at org.eclipse.e4.core.internal.di.InjectorImpl.disposed(InjectorImpl.java:450)
at org.eclipse.e4.core.internal.di.Requestor.disposed(Requestor.java:156)
at org.eclipse.e4.core.internal.contexts.ContextObjectSupplier$ContextInjectionListener.update(ContextObjectSupplier.java:78)
at org.eclipse.e4.core.internal.contexts.TrackableComputationExt.update(TrackableComputationExt.java:111)
at org.eclipse.e4.core.internal.contexts.TrackableComputationExt.handleInvalid(TrackableComputationExt.java:74)
at org.eclipse.e4.core.internal.contexts.EclipseContext.dispose(EclipseContext.java:178)
at org.eclipse.e4.core.internal.contexts.osgi.EclipseContextOSGi.dispose(EclipseContextOSGi.java:99)
at org.eclipse.e4.core.internal.contexts.osgi.EclipseContextOSGi.bundleChanged(EclipseContextOSGi.java:141)
at org.eclipse.osgi.internal.framework.BundleContextImpl.dispatchEvent(BundleContextImpl.java:908)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.ListenerQueue.dispatchEventSynchronous(ListenerQueue.java:148)
at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEventPrivileged(EquinoxEventPublisher.java:213)
at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEvent(EquinoxEventPublisher.java:120)
at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEvent(EquinoxEventPublisher.java:112)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor.publishModuleEvent(EquinoxContainerAdaptor.java:168)
at org.eclipse.osgi.container.Module.publishEvent(Module.java:476)
at org.eclipse.osgi.container.Module.doStop(Module.java:634)
at org.eclipse.osgi.container.Module.stop(Module.java:498)
at org.eclipse.osgi.container.SystemModule.stop(SystemModule.java:202)
at org.eclipse.osgi.internal.framework.EquinoxBundle$SystemBundle$EquinoxSystemModule$1.run(EquinoxBundle.java:165)
at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: java.lang.ClassNotFoundException: javax.annotation.PreDestroy cannot be found by org.eclipse.e4.core.di_1.6.100.v20170421-1418
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:433)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:395)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:387)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:150)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
... 21 more



Können Sie helfen oder lösche ich den Versuch wieder?

Gruß und schönen Tag!
Re: Fehler nach Installation
03. Juli 2019 09:43
Moin,
probier mal bitte mit Java 8.

Viele Grüße,
Ralf.
Re: Fehler nach Installation
03. Juli 2019 13:13
Hallo,

auf meinem Rechner (OS: Windows 7 pro 64Bit) läuft lt. Java-Info bereits Java Version 8 Update 211 (Build 1.8.0_211-b12)

Gruß
Re: Fehler nach Installation
03. Juli 2019 14:46
Aber Fakturama wurde mit Java 11 gestartet:
java.version=11.0.2

Viele Grüße,
Ralf.
Re: Fehler nach Installation
03. Juli 2019 15:26
ja schade, hilft nicht. Habe Java runtergeworfen, die 8er Version bei Oracle runtergeladen und installiert. Das Verhalten bliebt identisch und in der .log steht nach wie vor java.version=11.0.2

Keine Ahnung wo das herkommt ...

Gruß
Re: Fehler nach Installation
04. Juli 2019 23:23
Installation hat nun funktioniert, habe über einen Eintrag hier im Forum 'ne olle 8er Java Version gefunden, installiert und läuft erstmal. Warum mein Rechner Java 8 anzeigt und die .log - Datei eine 11er Version unterstellt, ist mir allerdings schleierhaft.

Gruß
Re: Fehler nach Installation
12. Juli 2019 20:28
Nicht nur die Java-Version muss stimmen. Übereinstimmen muss auch Fakturama 64 bit mit einer 64bit Java-Version, bzw. 32bit mit 32bit.
Evt. sind zwei unterschiedliche Java-Version für 32bit Programme und 64bit Programme installiert gewesen.

------------------------------------------------------------
Fakturama 2.0.3
Ubuntu@WAN 16.04.6 | Win10@LAN 18.09 | MySQL 5.7.26@UbuntuServer 18.04.2 | QRK
------------------------------------------------------------
Re: Fehler nach Installation
28. Juli 2019 13:27
Hallo,

habe mir heute ebenfalls Fakturama installiert.
(Betriebssystem Ubuntu 18.04.2 LTS 64-bit Gnome 3.28.2)

Den Hinweisen unter "[www.fakturama.info]; folgend, habe ich zuerst Java12 von Oracle installiert. Der erste Start brachte dann nachfolgende Fehlermeldung: "Ein Fehler ist aufgetreten. Informationen hierzu..."

Nach Recherchen hier im Forum erhielt ich die Erkenntnis, es mit Jawa8 zu versuchen.
Also habe ich Java12 wieder entfernt und OpenJDK 8 installiert.

Nun bringt auch der zweite Start die Fehlermeldung: "Ein Fehler ist aufgetreten. Informationen hierzu..."

Laut log-Datei hat Fakturama versucht, mit
java.version=11.0.3
java.vendor=Oracle Corporation
zu starten (Inhalt der gesamten log-Datei ist abschließend ersichtlich)

Wie bekomme ich bloß die richtige Java-Version für Fakturama eingestellt?

Gesamter Inhalt der log-Datei:

!SESSION 2019-07-28 12:52:41.889 -----------------------------------------------
eclipse.buildId=2.0.4.
java.version=11.0.3
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=de_DE
Command-line arguments: -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.osgi.compatibility.state.nl_eu 2 0 2019-07-28 12:52:54.695
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_eu [6]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_ru 2 0 2019-07-28 12:52:54.695
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_ru [12]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_tr 2 0 2019-07-28 12:52:54.695
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_tr [13]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.e4.ui.swt.gtk.nl_fr 2 0 2019-07-28 12:52:54.696
!MESSAGE Could not resolve module: org.eclipse.e4.ui.swt.gtk.nl_fr [472]
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk


!ENTRY org.eclipse.e4.ui.swt.gtk.nl_hu 2 0 2019-07-28 12:52:54.696
!MESSAGE Could not resolve module: org.eclipse.e4.ui.swt.gtk.nl_hu [473]
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk


!ENTRY org.eclipse.e4.ui.swt.gtk.nl_es 2 0 2019-07-28 12:52:54.696
!MESSAGE Could not resolve module: org.eclipse.e4.ui.swt.gtk.nl_es [470]
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk


!ENTRY org.eclipse.e4.ui.swt.gtk.nl_ro 2 0 2019-07-28 12:52:54.696
!MESSAGE Could not resolve module: org.eclipse.e4.ui.swt.gtk.nl_ro [476]
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk


!ENTRY org.eclipse.osgi.compatibility.state.nl_de 2 0 2019-07-28 12:52:54.697
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_de [3]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_el 2 0 2019-07-28 12:52:54.697
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_el [4]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_fr 2 0 2019-07-28 12:52:54.697
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_fr [7]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_es 2 0 2019-07-28 12:52:54.697
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_es [5]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_hu 2 0 2019-07-28 12:52:54.698
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_hu [8]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_ro 2 0 2019-07-28 12:52:54.698
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_ro [11]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_pl 2 0 2019-07-28 12:52:54.698
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_pl [10]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.e4.ui.swt.gtk.nl_uk 2 0 2019-07-28 12:52:54.699
!MESSAGE Could not resolve module: org.eclipse.e4.ui.swt.gtk.nl_uk [479]
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk


!ENTRY org.eclipse.e4.ui.swt.gtk.nl_de 2 0 2019-07-28 12:52:54.699
!MESSAGE Could not resolve module: org.eclipse.e4.ui.swt.gtk.nl_de [468]
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk


!ENTRY org.eclipse.e4.ui.swt.gtk.nl_eu 2 0 2019-07-28 12:52:54.699
!MESSAGE Could not resolve module: org.eclipse.e4.ui.swt.gtk.nl_eu [471]
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk


!ENTRY org.eclipse.e4.ui.swt.gtk.nl_it 2 0 2019-07-28 12:52:54.699
!MESSAGE Could not resolve module: org.eclipse.e4.ui.swt.gtk.nl_it [474]
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk


!ENTRY org.eclipse.e4.ui.swt.gtk.nl_pl 2 0 2019-07-28 12:52:54.700
!MESSAGE Could not resolve module: org.eclipse.e4.ui.swt.gtk.nl_pl [475]
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk


!ENTRY org.eclipse.e4.ui.swt.gtk.nl_ru 2 0 2019-07-28 12:52:54.700
!MESSAGE Could not resolve module: org.eclipse.e4.ui.swt.gtk.nl_ru [477]
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk


!ENTRY org.eclipse.osgi.compatibility.state.nl_uk 2 0 2019-07-28 12:52:54.700
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_uk [14]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.e4.ui.swt.gtk.nl_tr 2 0 2019-07-28 12:52:54.700
!MESSAGE Could not resolve module: org.eclipse.e4.ui.swt.gtk.nl_tr [478]
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk


!ENTRY org.eclipse.osgi.compatibility.state.nl_it 2 0 2019-07-28 12:52:54.701
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_it [9]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.e4.ui.swt.gtk.nl_ar 2 0 2019-07-28 12:52:54.701
!MESSAGE Could not resolve module: org.eclipse.e4.ui.swt.gtk.nl_ar [467]
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk


!ENTRY org.eclipse.osgi.compatibility.state.nl_ar 2 0 2019-07-28 12:52:54.701
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_ar [2]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.e4.ui.swt.gtk.nl_el 2 0 2019-07-28 12:52:54.701
!MESSAGE Could not resolve module: org.eclipse.e4.ui.swt.gtk.nl_el [469]
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk
Unresolved requirement: Fragment-Host: org.eclipse.e4.ui.swt.gtk


!ENTRY org.eclipse.osgi 4 0 2019-07-28 12:52:54.702
!MESSAGE Anwendungsfehler
!STACK 1
org.eclipse.e4.core.di.InjectionException: java.lang.NoClassDefFoundError: javax/annotation/PostConstruct
at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:410)
at org.eclipse.e4.core.internal.di.InjectorImpl.make(InjectorImpl.java:318)
at org.eclipse.e4.core.contexts.ContextInjectionFactory.make(ContextInjectionFactory.java:162)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createDefaultHeadlessContext(E4Application.java:491)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createDefaultContext(E4Application.java:505)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createE4Workbench(E4Application.java:204)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.start(E4Application.java:149)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.base/java.lang.reflect.Method.invoke(Method.java:566)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
at org.eclipse.equinox.launcher.Main.run(Main.java:1499)
at org.eclipse.equinox.launcher.Main.main(Main.java:1472)
Caused by: java.lang.NoClassDefFoundError: javax/annotation/PostConstruct
at org.eclipse.e4.core.internal.di.InjectorImpl.inject(InjectorImpl.java:124)
at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:399)
... 19 more
Caused by: java.lang.ClassNotFoundException: javax.annotation.PostConstruct cannot be found by org.eclipse.e4.core.di_1.6.100.v20170421-1418
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:433)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:395)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:387)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:150)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
... 21 more

!ENTRY org.eclipse.e4.ui.workbench 4 0 2019-07-28 12:52:54.708
!MESSAGE FrameworkEvent ERROR
!STACK 0
java.lang.NoClassDefFoundError: javax/annotation/PreDestroy
at org.eclipse.e4.core.internal.di.InjectorImpl.disposed(InjectorImpl.java:450)
at org.eclipse.e4.core.internal.di.Requestor.disposed(Requestor.java:156)
at org.eclipse.e4.core.internal.contexts.ContextObjectSupplier$ContextInjectionListener.update(ContextObjectSupplier.java:78)
at org.eclipse.e4.core.internal.contexts.TrackableComputationExt.update(TrackableComputationExt.java:111)
at org.eclipse.e4.core.internal.contexts.TrackableComputationExt.handleInvalid(TrackableComputationExt.java:74)
at org.eclipse.e4.core.internal.contexts.EclipseContext.dispose(EclipseContext.java:178)
at org.eclipse.e4.core.internal.contexts.osgi.EclipseContextOSGi.dispose(EclipseContextOSGi.java:99)
at org.eclipse.e4.core.internal.contexts.osgi.EclipseContextOSGi.bundleChanged(EclipseContextOSGi.java:141)
at org.eclipse.osgi.internal.framework.BundleContextImpl.dispatchEvent(BundleContextImpl.java:908)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.ListenerQueue.dispatchEventSynchronous(ListenerQueue.java:148)
at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEventPrivileged(EquinoxEventPublisher.java:213)
at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEvent(EquinoxEventPublisher.java:120)
at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEvent(EquinoxEventPublisher.java:112)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor.publishModuleEvent(EquinoxContainerAdaptor.java:168)
at org.eclipse.osgi.container.Module.publishEvent(Module.java:476)
at org.eclipse.osgi.container.Module.doStop(Module.java:634)
at org.eclipse.osgi.container.Module.stop(Module.java:498)
at org.eclipse.osgi.container.SystemModule.stop(SystemModule.java:202)
at org.eclipse.osgi.internal.framework.EquinoxBundle$SystemBundle$EquinoxSystemModule$1.run(EquinoxBundle.java:165)
at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: java.lang.ClassNotFoundException: javax.annotation.PreDestroy cannot be found by org.eclipse.e4.core.di_1.6.100.v20170421-1418
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:433)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:395)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:387)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:150)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
... 21 more

Mit der Bitte um Hilfe verbleibt mit besten Grüßen

Dirk
Re: Fehler nach Installation
28. Juli 2019 13:32
Hallo Dirk,
Du benötigst Java 8.x

------------------------------------------------------------
Fakturama 2.0.3
Ubuntu@WAN 16.04.6 | Win10@LAN 18.09 | MySQL 5.7.26@UbuntuServer 18.04.2 | QRK
------------------------------------------------------------
Re: Fehler nach Installation
28. Juli 2019 13:50
Hallo nicoletta,

hab Dank für deine Zeilen.

Wie schon geschrieben, habe ich Java 8 (mittels "sudo apt-get install openjdk-8-jre"winking smiley installiert. Im Terminal wurde ausgegeben, dass die neueste Version von openjdk-8-jre bereits installiert ist.
Oder meinst du Oracle Java 8?
Re: Fehler nach Installation
28. Juli 2019 16:06
Es muss nicht unbedingt Oracle sein, aber Du hast scheinbar nun beide versionen installiert. Nun musst Du noch auf Version 8 umschalten.

Zitat
java -version
Zitat
sudo update-alternatives --config java

------------------------------------------------------------
Fakturama 2.0.3
Ubuntu@WAN 16.04.6 | Win10@LAN 18.09 | MySQL 5.7.26@UbuntuServer 18.04.2 | QRK
------------------------------------------------------------
Re: Fehler nach Installation
30. Juli 2019 21:42
Liebe nicoletta,

zack, das war es!

Mittels "java -version" habe ich herausgefunden, dass die 11 läuft.
Und mittels "sudo update-alternatives --config java" konnte ich die Version 8 einstellen.

Nach dem erneuten Start von Fakturama lief alles nach Plan.
Aufgrund einer Umstellung von W7 nach ubuntu (noch als Dual-Boot) konnte ich sogar das alte Arbeitsverzeichnis aus W7 ins neue übernehmen...

Krasses Pferd!

Also noch einmal vielen Dank für deine Hilfe.

Beste Grüße - Dirk
Re: Fehler nach Installation
28. August 2019 16:22
nicoletta schrieb:
-------------------------------------------------------
> Es muss nicht unbedingt Oracle sein, aber Du hast
> scheinbar nun beide versionen installiert. Nun
> musst Du noch auf Version 8 umschalten.
>
>
Zitat
java -version
>
Zitat
sudo update-alternatives --config
> java


Zur Info: Diese Lösung funktioniert auch unter Ubuntu 18.04 LTS.
Re: Fehler nach Installation
19. September 2019 07:46
Muss mich hier mal einklinken. Habe auf meinem Win 10 Rechner installiert, aber es lässt sich nicht starten.
Was kann ich unternehmen damit ich fakturama 2 nutzen kann?

Link zum Fehler
Re: Fehler nach Installation
19. September 2019 08:42
Moin,
hast Du mal geprüft, welche Java-Version bei Dir läuft?

Viele Grüße,
Ralf.
Re: Fehler nach Installation
19. September 2019 09:00
vers 8 upd. 221 build 1.8.0_221-b11

Hab jetzt noch eine log in den Link gemacht.
Bin für jede Hilfestellung dankbar.



2-mal bearbeitet. Zuletzt am 19.09.19 11:08.
Re: Fehler nach Installation
19. September 2019 12:32
Moin,
ich finde die Lösung mit dem Eintrag in der Fakturama.ini Datei am besten.
Bei mir, Debian Linux habe ich die Java 8 und die aktuelle Java 12 insraliert.
Das gute dabei ist, dass die Java 8 muss nicht als Standard laufen und es funktioniert wunderbar.

Idealweise könnt man die Javanbindung über Einstellungsmenü der Fakturama einrichten.
Selbstverständlich gleich bei der Installation so wie nachträglich über Einstalungsmenü.

So eine Möglichkeit gibt schon bei LO. Über Extras/Optionen/Erweitert kann man die verfügbare Java Instalationen anschauen und auswählen.

Viele Grüße
Marek
Re: Fehler nach Installation
19. September 2019 13:08
pillango schrieb:
-------------------------------------------------------
> Moin,
> ich finde die Lösung mit dem Eintrag in der
> Fakturama.ini Datei am besten.
> Bei mir, Debian Linux habe ich die Java 8 und die
> aktuelle Java 12 insraliert.
> Das gute dabei ist, dass die Java 8 muss nicht als
> Standard laufen und es funktioniert wunderbar.
>
> Idealweise könnt man die Javanbindung über
> Einstellungsmenü der Fakturama einrichten.
> Selbstverständlich gleich bei der Installation so
> wie nachträglich über Einstalungsmenü.
>
> So eine Möglichkeit gibt schon bei LO. Über
> Extras/Optionen/Erweitert kann man die verfügbare
> Java Instalationen anschauen und auswählen.
>
> Viele Grüße
> Marek

Hallo kläre mich mal bitte auf welchen Eintrag in die .ini .
Re: Fehler nach Installation
19. September 2019 13:23
Moin,

hier ist es beschrieben.
[forum.fakturama.info]

Gruß
Marek
Re: Fehler nach Installation
19. September 2019 14:00
Funktioniert es hat die 64-bit java gefehlt.

Danke für eure Hilfe
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen