Fehler bei erstem Start
20. Mai 2019 00:15
Hallo Zusammen,
beim ersten Start der App auf meinem Mac bekomme ich einen Fehler angezeigt und die App startet nicht. Das Log-File sagt folgendes:

<log>

!SESSION 2019-05-20 00:08:03.424 -----------------------------------------------
eclipse.buildId=2.0.4.
java.version=11.0.3
java.vendor=Oracle Corporation
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=en_DE
Framework arguments: -keyring /Users/doc/.eclipse_keyring
Command-line arguments: -os macosx -ws cocoa -arch x86_64 -keyring /Users/doc/.eclipse_keyring

!ENTRY org.eclipse.osgi.compatibility.state.nl_de 2 0 2019-05-20 00:08:06.027
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_de [3]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_tr 2 0 2019-05-20 00:08:06.028
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_tr [13]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_eu 2 0 2019-05-20 00:08:06.028
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_eu [6]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_ru 2 0 2019-05-20 00:08:06.028
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_ru [12]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_hu 2 0 2019-05-20 00:08:06.028
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_hu [8]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_es 2 0 2019-05-20 00:08:06.028
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_es [5]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_fr 2 0 2019-05-20 00:08:06.028
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_fr [7]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_pl 2 0 2019-05-20 00:08:06.029
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_pl [10]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_uk 2 0 2019-05-20 00:08:06.029
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_uk [14]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_it 2 0 2019-05-20 00:08:06.029
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_it [9]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_el 2 0 2019-05-20 00:08:06.029
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_el [4]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_ar 2 0 2019-05-20 00:08:06.029
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_ar [2]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_ro 2 0 2019-05-20 00:08:06.030
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_ro [11]
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi 4 0 2019-05-20 00:08:06.030
!MESSAGE Application error
!STACK 1
org.eclipse.e4.core.di.InjectionException: java.lang.NoClassDefFoundError: javax/annotation/PostConstruct
at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:410)
at org.eclipse.e4.core.internal.di.InjectorImpl.make(InjectorImpl.java:318)
at org.eclipse.e4.core.contexts.ContextInjectionFactory.make(ContextInjectionFactory.java:162)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createDefaultHeadlessContext(E4Application.java:491)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createDefaultContext(E4Application.java:505)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createE4Workbench(E4Application.java:204)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.start(E4Application.java:149)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.base/java.lang.reflect.Method.invoke(Method.java:566)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
at org.eclipse.equinox.launcher.Main.run(Main.java:1499)
Caused by: java.lang.NoClassDefFoundError: javax/annotation/PostConstruct
at org.eclipse.e4.core.internal.di.InjectorImpl.inject(InjectorImpl.java:124)
at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:399)
... 18 more
Caused by: java.lang.ClassNotFoundException: javax.annotation.PostConstruct cannot be found by org.eclipse.e4.core.di_1.6.100.v20170421-1418
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:433)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:395)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:387)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:150)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
... 20 more

!ENTRY org.eclipse.e4.ui.workbench 4 0 2019-05-20 00:08:06.034
!MESSAGE FrameworkEvent ERROR
!STACK 0
java.lang.NoClassDefFoundError: javax/annotation/PreDestroy
at org.eclipse.e4.core.internal.di.InjectorImpl.disposed(InjectorImpl.java:450)
at org.eclipse.e4.core.internal.di.Requestor.disposed(Requestor.java:156)
at org.eclipse.e4.core.internal.contexts.ContextObjectSupplier$ContextInjectionListener.update(ContextObjectSupplier.java:78)
at org.eclipse.e4.core.internal.contexts.TrackableComputationExt.update(TrackableComputationExt.java:111)
at org.eclipse.e4.core.internal.contexts.TrackableComputationExt.handleInvalid(TrackableComputationExt.java:74)
at org.eclipse.e4.core.internal.contexts.EclipseContext.dispose(EclipseContext.java:178)
at org.eclipse.e4.core.internal.contexts.osgi.EclipseContextOSGi.dispose(EclipseContextOSGi.java:99)
at org.eclipse.e4.core.internal.contexts.osgi.EclipseContextOSGi.bundleChanged(EclipseContextOSGi.java:141)
at org.eclipse.osgi.internal.framework.BundleContextImpl.dispatchEvent(BundleContextImpl.java:908)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.ListenerQueue.dispatchEventSynchronous(ListenerQueue.java:148)
at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEventPrivileged(EquinoxEventPublisher.java:213)
at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEvent(EquinoxEventPublisher.java:120)
at org.eclipse.osgi.internal.framework.EquinoxEventPublisher.publishBundleEvent(EquinoxEventPublisher.java:112)
at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor.publishModuleEvent(EquinoxContainerAdaptor.java:168)
at org.eclipse.osgi.container.Module.publishEvent(Module.java:476)
at org.eclipse.osgi.container.Module.doStop(Module.java:634)
at org.eclipse.osgi.container.Module.stop(Module.java:498)
at org.eclipse.osgi.container.SystemModule.stop(SystemModule.java:202)
at org.eclipse.osgi.internal.framework.EquinoxBundle$SystemBundle$EquinoxSystemModule$1.run(EquinoxBundle.java:165)
at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: java.lang.ClassNotFoundException: javax.annotation.PreDestroy cannot be found by org.eclipse.e4.core.di_1.6.100.v20170421-1418
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:433)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:395)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:387)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:150)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
... 21 more

</log>

Hat jemand einenTipp, was das Problem sein könnte? Danke.
Re: Fehler bei erstem Start
22. Mai 2019 16:40
So wie es ausschaut hast Du Java in der Version 11 installiert.
Mit JAVA in der Version 8.x gibt es keine Probleme.

------------------------------------------------------------
Fakturama 2.0.3
Ubuntu@WAN 16.04.6 | Win10@LAN 18.09 | MySQL 5.7.26@UbuntuServer 18.04.2 | QRK
------------------------------------------------------------
Re: Fehler bei erstem Start
22. Mai 2019 23:03
Hi, danke für den Tipp. Aber warum soll ich eine auslaufende Java-Version verwenden? Auf der Fakturama-Downloadseite steht "Fakturama benötigt Java 8 oder neuer". Da sollte es doch mit Java 11 oder 12 funktionieren, oder nicht?
Re: Fehler bei erstem Start
23. Mai 2019 15:44
ich habe das gleiche Problem, bei mir funktioniert es leider auch nicht.
Re: Fehler bei erstem Start
24. Mai 2019 22:36
Es geht wirklich nicht mit Java 11.

Viele Grüße,
Ralf.
Re: Fehler bei erstem Start
25. Mai 2019 12:24
Ich habe Java 8 installiert trotzdem gehts bei mir nicht.
Re: Fehler bei erstem Start
25. Mai 2019 12:32
Es mag sein das Du Java 8 installiert hast. Laut dem Log hast Du nicht Java 8 aktiv.

Zitat
!SESSION 2019-05-20 00:08:03.424 ----------------------------------------------- eclipse.buildId=2.0.4. java.version=11.0.3 java.vendor=Oracle Corporation

------------------------------------------------------------
Fakturama 2.0.3
Ubuntu@WAN 16.04.6 | Win10@LAN 18.09 | MySQL 5.7.26@UbuntuServer 18.04.2 | QRK
------------------------------------------------------------
Re: Fehler bei erstem Start
25. Mai 2019 15:45
rheydenr schrieb:
-------------------------------------------------------
> Es geht wirklich nicht mit Java 11.

Updates für Java 8 sind für kommerzielle Nutzer bereits eingestellt, für Privat wird es bis 2020 eingestellt. Das werd ich mir jetzt nicht noch installieren. Wann kommt denn ein Update für Fakturama für Java 12? Kommt so etwas überhaupt, wie ist denn die Roadmap?

Auf der Downloadseite steht "Java 8 oder neuer". Könnte man da nicht mal besser schreiben "Java 8 - Java 10", oder was auch immer die letzte für Fakturama nutzbare Java-Version ist?
Re: Fehler bei erstem Start
25. Mai 2019 21:28
Naja gut, ich hab mir Java 8 doch mal installiert, allerdings in der Version von [adoptopenjdk.net]. Jetzt funktioniert es. Aber eine Version für Java 11 LTS wäre vielleicht nicht schlecht.
Re: Fehler bei erstem Start
28. Mai 2019 18:39
Eine Version f´ür Java 11 habe ich zwar geplant, weiß aber noch nicht, wann die kommt. Es ist ziemlich kompliziert, das umzustellen, zumal ich auch auf OpenJDK wechseln muß.

Viele Grüße,
Ralf.
Re: Fehler bei erstem Start
28. Mai 2019 23:03
rheydenr schrieb:
-------------------------------------------------------
> Eine Version f´ür Java 11 habe ich zwar geplant,
> weiß aber noch nicht, wann die kommt. Es ist
> ziemlich kompliziert, das umzustellen, zumal ich
> auch auf OpenJDK wechseln muß.


Ok. Danke für die Antwort.
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen