Gelöst! thumbs upUpdate Fehlgeschlagen

geschrieben von Manuel CircO 
Willkommen! Anmelden Ein neues Profil erzeugen Suche
Gelöst! thumbs upUpdate Fehlgeschlagen
19. März 2019 11:16
Hallo,

ich habe gestern versucht Fakturama zu updaten. (Meine PC: Ubuntu 18, Java 8)

Jetzt öffnet sich Fakturama nicht mehr:

Das hier gibt das Terminal aus:
WARNING: Extender - Refreshing disabled - entities in bundle com.sebulli.fakturama.model may not be woven

[...]

(SWT:10876): GLib-CRITICAL **: 17:38:45.844: g_base64_encode_step: assertion 'in != NULL' failed
applicationXMI parameter not set and no branding plugin defined. 
java.lang.Exception
	at org.eclipse.e4.ui.internal.workbench.swt.E4Application.lambda$12(E4Application.java:397)
	at java.util.Optional.orElseGet(Optional.java:267)
	at org.eclipse.e4.ui.internal.workbench.swt.E4Application.determineApplicationModelURI(E4Application.java:391)
	at org.eclipse.e4.ui.internal.workbench.swt.E4Application.loadApplicationModel(E4Application.java:349)
	at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createE4Workbench(E4Application.java:253)
	at org.eclipse.e4.ui.internal.workbench.swt.E4Application.start(E4Application.java:149)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:498)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1499)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1472)

und hier findet ihr das logfile:
https://pastebin.com/W78udYNF

Habt ihr einen Tip für mich?

Grüße
Manuel



1-mal bearbeitet. Zuletzt am 21.03.19 16:41.
Re: Update Fehlgeschlagen
19. März 2019 12:48
habe das gleiche Spiel auf einer anderen Maschine ausprobiert (Debian 9) und habe das gleiche Problem. Gibt es noch die Möglichkeit zum Downgrade?
Re: Update Fehlgeschlagen
19. März 2019 20:26
Ich check das einfach nicht... Ich lösch die Version wieder und teste erst mal weiter.

Nachtrag: Ich hab die Version jetzt zurückgesetzt und das automatische Update deaktiviert (da kommt jetzt eine Fehlermeldung). In dem von Dir geposteten Logfile sieht es aus, als ob bestimmte Abhängigkeiten zu verschiedenen Programmteilen nicht aufgelöst werden konnten (wobei mich die Versionsangabe "2.0.0" bißchen irritiert hat).
Zum Zurücksetzen folgendermaßen vorgehen:
  • Datensicherung
  • Fakturama deinstallieren
  • Fakturama 2.0.3 installieren
  • .fakturama2 (Verzeichnis im Home-Verzeichnis) löschen / umbenennen
  • ein evtl. vorhandenes Verzeichnis ".eclipse" (im Home-Verzeichnis) ebenfalls löschen

Viele Grüße,
Ralf.



1-mal bearbeitet. Zuletzt am 19.03.19 20:48.
Re: Update Fehlgeschlagen
20. März 2019 13:52
Es hat funktioniert! Vielen Vielen Dank!
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen