Spracheinstellungen

geschrieben von hik 
Willkommen! Anmelden Ein neues Profil erzeugen Suche
hik
Spracheinstellungen
15. Januar 2019 18:42
Ich habe bisher Fakturama auf einem Linux-Rechner benutzt. Nach anfänglichen Schwierigkeiten habe ich nun Fakturama2 auf einem Mac als Nachfolgerechner zum Laufen gekriegt.

Bei folgenden Problemen brauche ich Hilfe:

1) Bei der Rechnungsaufstellung wird eine Zahl in der Spalte "Anzahl" in englischer Schreibweise mit DezimalPUNKT (1,000.00) dargestellt. Bei der Währung die deutsche Schreibweise mit DezimalKOMMA. Die Menüsprache und sonst alles ist auch deutsch.

2) Bei der Spalte "Anzahl" kann es sporadisch vorkommen, dass einer Zahl plötzlich zwei Nullen spendiert wird. Aus 105.00 wird dann 10500.00.

3) Bei der Generierung von PDF wird auch das englische Datum eingesetzt, etwa Oct 17, 2018 statt etwa 17. Okt. 2018.

Wie lässt sich alles auf deutsch abändern?


Danke für jegliche Hilfe
Thorsten
hik
Re: Spracheinstellungen
15. Januar 2019 18:52
So. Problem 1) ist lösbar, indem in der Datei "/Applications/Fakturama/Fakturama.app/Contents/MacOS/Fakturama.ini" die folgenden Parameter ergänzt werden:

-Duser.country=DE
-Duser.language=de

Jetzt knabbere ich noch an 3) ...
Re: Spracheinstellungen
15. Januar 2019 20:39
Hallo hik,
da bist Du jetzt schon der zweite User, der das meldet. Hier ist ein weiterer Thread, in dem das Thema behandelt wird. Ich kann es derzeit nicht nachstellen. Warum man explizit die Ländereinstellung setzen muß ist mir auch nicht klar. Das habe ich bislang ebenfalls nicht beobachten können.

Viele Grüße,
Ralf.
hik
Re: Spracheinstellungen
16. Januar 2019 08:23
Offenbar hat die Sprachinstellung für JAVA nun auch das Problem für 3) gelöst. Spricht: Die Monatsnamen werden jetzt korrekt angezeigt. Ich habe keine Ahnung, wieso das nicht sofort "durchgesickert", aber jetzt passt es.
Re: Spracheinstellungen
16. Januar 2019 20:29
Hallo hik,
da würde mich aber echt interessieren, was Du geändert hast. Direkt in den Java-Einstellungen die Sprache geändert?

Viele Grüße,
Ralf.
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen