[MacOS Mojave] Update Problem 1.6.5->1.6.9 (danach vielleicht nach 2.x)

geschrieben von Sedrah 
Willkommen! Anmelden Ein neues Profil erzeugen Suche
[MacOS Mojave] Update Problem 1.6.5->1.6.9 (danach vielleicht nach 2.x)
07. Januar 2019 18:55
Moin,

erstmal das was so drum rum los ist:
nach langer Fakturama-Abstinenz und Genesung nach einem Unfall benötige ich einmal Hilfe.
Ich habe aktuell noch 1.6.5 auf meinem Mac am laufen (und läuft auch gut) dann mal geguckt ob es was neues gibt und siehe da - 2.x thumbs up Runtergeladen installiert und... Hälfte fehlt... Gut erst lesen, dann denken, dann handeln... Gesehen dass ich min. 1.6.9 haben muss, um auf 2.x zu updaten und danach glücklich zu sein.

Hier gehts richtig los
1.6.9c von Sourceforge geladen und versucht zu "installieren" nach dem Start eine Fehlermeldung bekommen mich an das Starproblem erinnert und die aktuelle Java Version in die ini eingetragen

-startup
plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
-vm
/Library/Java/JavaVirtualMachines/jdk1.7.0_80.jdk/Contents/Home
--launcher.library
plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.101.v20120109-1504
-vmargs
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
-Xdock:name=Fakturama

und jetzt bekomme ich ein anderen Fehler... Error occured...
hier mal das Log-File

DESKTOP-EB7ONP4:~ einganzdooferbenutzername$ cat /Applications/Fakturama.app/Contents/MacOS/configuration/1546880632923.log
!SESSION 2019-01-07 18:03:52.475 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_65
java.vendor=Apple Inc.
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=de_DE
Framework arguments:  -keyring /Users/einganzdooferbenutzername/.eclipse_keyring -showlocation
Command-line arguments:  -os macosx -ws cocoa -arch x86_64 -keyring /Users/einganzdooferbenutzername/.eclipse_keyring -showlocation

!ENTRY org.eclipse.osgi 2 0 2019-01-07 18:03:53.697
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2019-01-07 18:03:53.697
!MESSAGE Bundle com.sebulli.fakturama_1.6.9 [5] was not resolved.
!SUBENTRY 1 org.eclipse.osgi 2 0 2019-01-07 18:03:53.698
!MESSAGE Bundle com.sebulli.fakturama.help_1.6.9 [6] was not resolved.

!ENTRY org.eclipse.osgi 4 0 2019-01-07 18:03:53.699
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application "com.sebulli.fakturama.application" could not be found in the registry. The applications available are: org.eclipse.equinox.app.error, org.eclipse.equinox.p2.director, org.eclipse.equinox.p2.garbagecollector.application, org.eclipse.equinox.p2.publisher.InstallPublisher, org.eclipse.equinox.p2.publisher.EclipseGenerator, org.eclipse.equinox.p2.publisher.ProductPublisher, org.eclipse.equinox.p2.publisher.FeaturesAndBundlesPublisher, org.eclipse.equinox.p2.reconciler.application, org.eclipse.equinox.p2.repository.repo2runnable, org.eclipse.equinox.p2.repository.metadataverifier, org.eclipse.equinox.p2.artifact.repository.mirrorApplication, org.eclipse.equinox.p2.metadata.repository.mirrorApplication, org.eclipse.equinox.p2.updatesite.UpdateSitePublisher, org.eclipse.equinox.p2.publisher.UpdateSitePublisher, org.eclipse.equinox.p2.publisher.CategoryPublisher, org.eclipse.help.base.infocenterApplication, org.eclipse.help.base.helpApplication, org.eclipse.help.base.indexTool.
	at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:248)
	at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1410)

Hier hat bestimmt jemand einen super Tipp für mich. Dafür schon einmal ganz lieben Dank!
Gruß
Olli
Re: [MacOS Mojave] Update Problem 1.6.5->1.6.9 (danach vielleicht nach 2.x)
19. Februar 2019 18:20
Moin,

hat keiner eine Idee? Kann ich mir kaum vorstellen, dass ich damit alleine bin.

Gruß
Re: [MacOS Mojave] Update Problem 1.6.5->1.6.9 (danach vielleicht nach 2.x)
31. Mai 2019 23:57
Moin,
sorry, ich hab Deinen Beitrag irgendwie übersehen... Das Problem liegt darin, daß Du hier Java 6 verwendest (steht im Logfile ziemlich weit oben). Es geht aber erst mit Java 8. Kannst Du das nochmal ausprobieren?

Viele Grüße,
Ralf.
Re: [MacOS Mojave] Update Problem 1.6.5->1.6.9 (danach vielleicht nach 2.x)
01. Juni 2019 10:00
Hallo Ralf,

das kann passieren. Ich bin glücklich eine solche Software von euch zur Verfügung gestellt zu bekommen. Ich hatte vor Jahren auch schon mal Kontakt zu Peter bezüglich Hilfe und Virtualisierung. Dann kam aber bei mir erstmal alles anders als gedacht...

Ich hätte schwören können ich habe es mit der 8er Version probiert (installiert habe ich sie zumindest) aber vielleicht bin ich durcheinander gekommen und habe es bei der 1.6.5 in die ini eingetragen. Wie dem auch sei - mit 8 in der richtigen ini startet die Software in Version 1.6.9 thumbs up

Hast du noch ein Tipp wie ich den Import Dialog für die 2er Version wieder her zaubern kann? Dann dürfte die 2er auch bei mir laufen smiling bouncing smiley

Danke
Gruß
Olli
Re: [MacOS Mojave] Update Problem 1.6.5->1.6.9 (danach vielleicht nach 2.x)
01. Juni 2019 15:18
Moin,

hat sich geklärt. Ich habe das .Verzeichnis im Userhome gefunden und umbenannt - jetzt kam auch der Import Dialog wieder.

Ich habe noch ein "Problem"chen beim Ausdrucken bekomme ich die Fehlermeldung "Bestand kleiner gleich Null" Hierbei handelt es sich nur um Stundenlohn und selbst wenn ich den Lagerbestand auf einen großen Wert festlege wird er nach dem Erstellen wieder auf 1.0 zurückgesetzt. Gibt es hier etwas zu beachten? Eigentlich benötige ich keine Lagerbestandsüberwachung. Einfach in den Einstellungen angepasst dass der Laderbestand nicht angepasst werden soll - Funktioniert für mich smiling smiley

Danke



1-mal bearbeitet. Zuletzt am 01.06.19 15:21.
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen