Installationsprobleme bei Mac os

geschrieben von Gullyver 
Willkommen! Anmelden Ein neues Profil erzeugen Suche
Installationsprobleme bei Mac os
02. Mai 2018 08:25
Hallo Leute,

ich versuche schon seit Tagen Fakturama 2 auf meinem Mac zu installieren. Ich habe Java Version 8 update 172 installiert und lieber Office. Alle Versuche mit Umscheiben der ins.datei wahren bislang erfolglos.

Hier ist die Original ini Datei
-startup
../Eclipse/plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
--launcher.library
../Eclipse/plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.551.v20171108-1834
-vmargs
-DREFRESH_BUNDLES=false
-Dorg.eclipse.e4.ui.css.dynamic=true
-XstartOnFirstThread
-Dorg.eclipse.swt.internal.carbon.smallFonts
-Xdock:name=Fakturama
-Xdock:icon=../Resources/app.icns

Alle beschriebenen Korrekturen habe ich schon probiert und nichts funktioniert, habt Ihr noch eine Tipp oder eine Anleitung
Re: Installationsprobleme bei Mac os
02. Mai 2018 23:43
Hallo Gullyver,
gibt es denn irgendwo eine Fehlermeldung? Hast Du mal in die Logdatei unter ~/fakturama2/.metadata geschaut?

Viele Grüße,
Ralf.
Re: Installationsprobleme bei Mac os
03. Mai 2018 11:38
Hallo Ralf,

ich bekomme schon beim Startversuch eine Fehlermeldung die besagt "Fakturama2 ist beschädigt und kann nicht geöffnet werden".
Ein Löschen und erneuter Download brachte keine Veränderung. Eine LOG Datei in dem Verzeichnis Fakturama 2 kann ich nicht finden, das einzige was ich finden konnte habe ich mal angehängt. Das stammt aus dem Ordner Resources "info.plist"
Die Ordnerstruktur lautet "Contents mitten Unterordnern Eclipse,MacO,Resources"


<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<plist version="1.0">

<dict>
<key>CFBundleExecutable</key>
<string>Fakturama</string>
<key>CFBundleGetInfoString</key>
<string>Eclipse 4.7 for Mac OS X, Copyright IBM Corp. and others 2002, 2016. All rights reserved.</string>
<key>CFBundleIconFile</key>
<string>app.icns</string>
<key>CFBundleIdentifier</key>
<string>Fakturama.ID</string>
<key>CFBundleInfoDictionaryVersion</key>
<string>6.0</string>
<key>CFBundleName</key>
<string>Fakturama</string>
<key>CFBundlePackageType</key>
<string>APPL</string>
<key>CFBundleShortVersionString</key>
<string>2.0.1</string>
<key>CFBundleSignature</key>
<string>????</string>
<key>CFBundleVersion</key>
<string>2.0.1</string>
<key>NSHighResolutionCapable</key>
<true/>
<key>CFBundleDevelopmentRegion</key>
<string>English</string>
<key>Eclipse</key>
<array>
<!-- to use a specific Java version (instead of the platform's default) uncomment one of the following options,
or add a VM found via $/usr/libexec/java_home -V
<string>-vm</string><string>/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Commands/java</string>
<string>-vm</string><string>/Library/Java/JavaVirtualMachines/1.8.0.jdk/Contents/Home/bin/java</string>
-->
<string>-keyring</string>
<string>~/.eclipse_keyring</string>
</array>
<key>CFBundleDisplayName</key>
<string>Fakturama</string>
</dict>

</plist>


Vielleicht hilft Dir das weiter

Viele Grüße

Jens
Re: Installationsprobleme bei Mac os
03. Mai 2018 19:54
Die Logdatei ist im Finder leider etwas schwer zu finden. Geh mal bitte über eine Console (oder Terminal) und laß Dir dort die Datei ~/.fakturama2/.metadata/.log anzeigen (geht mit "less"winking smiley.

Viele Grüße,
Ralf.
Re: Installationsprobleme bei Mac os
03. Mai 2018 20:52
Hallo

ich kann leider auch über das Terminal die LOG Datei nicht finden. Ich habe bekomme im Finder alle Systemdateien angezeigt.
das eine was ich finden kann, ist der Unterordner META-INF, darin befindet sich aber auch keine Log Datei.

Ich bin etwas ratlos
Re: Installationsprobleme bei Mac os
03. Mai 2018 21:04
Nein, das ist nicht im Programmverzeichnis, sondern in Deinem Benutzerverzeichnis. Sollte es dort nichts geben prüfe bitte mal, welche Version Dir angezeigt wird, wenn Du "java -version" auf der Konsole (Terminal) eingibst.

Viele Grüße,
Ralf.
Re: Installationsprobleme bei Mac os
04. Mai 2018 09:04
Leider gibt es die Datei auch nicht im Nutzerverzeichnis. Meine Java Version laut Terminal

java version "1.8.0_172"
Java(TM) SE Runtime Environment (build 1.8.0_172-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.172-b11, mixed mode)

Wie ich hier auch schon lesen konnte, gibt es beim Startversuch einen Hinweis auf die Log Datei, das passiert bei mir nicht.
Re: Installationsprobleme bei Mac os
04. Mai 2018 12:30
das habe ich jetzt doch noch gefunden


!SESSION Mon Apr 23 07:38:30 GMT+01:00 2018 ------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2018-04-23 07:38:30.951
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.UnsupportedClassVersionError: org/eclipse/core/runtime/adaptor/EclipseStarter : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:650)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
at org.eclipse.equinox.launcher.Main.run(Main.java:1499)

vielleicht ist die ja richtig
Re: Installationsprobleme bei Mac os
04. Mai 2018 22:17
exakt. Der Fehler wird hier benannt: "Unsupported major.minor version 51.0". Dazu gibt es hier einen Beitrag. Irgendwo schlummert bei Dir noch eine alte Java-Version herum. Die muß erst weg. Oder Du gibst das explizit in der Fakturama.ini an (per Schalter -vm).

Viele Grüße,
Ralf.
Re: Installationsprobleme bei Mac os
07. Mai 2018 11:21
Hallo,

ich habe sowohl im Finder als auch im Terminal, keine weitere Java Version gefunden. Auch nachdem ich die Java Komponenten komplett gelöscht habe, nach einem Neustart und einer neuen Installation von Java 8 tut sich nichts.

Was müsste ich in die Fakturama.ini eintragen um diesen Fehler zu umgehen?
Die hier beschriebene Umgehungslösung funktioniert auch nicht.

Ich habe Fakturama2 in einer virtuellen Maschine unter Win 7 laufen, das funktioniert einwandfrei ohne Probleme.

Viele Grüße
Jens
Re: Installationsprobleme bei Mac os
31. Mai 2018 22:05
Hallo Jens,
am besten gehst Du dazu im Terminal ins Wurzel-Verzeichnis ("cd /"winking smiley, tippst dort "find . -name java" ein und gehst einen Kaffee trinken :-) Im Anschluß steht im Terminal alles, was irgendwie "java" heißt. Darunter müßten auch alle installierten Java-Umgebungen sein. Dort mußt Du Dir die 8er-Version heraussuchen und den Pfad in die Fakturama.ini reinschreiben wie im Workaround beschrieben.

Viele Grüße,
Ralf.
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen