Eclipse-Probleme
07. Januar 2018 18:23
Hallo zusammen,


ein frisch installiertes Java 9 unter Windows 7 64bit und Fakturama 2.0.0 ohne Daten führt zu folgendem Problem:

!SESSION 2018-01-07 18:10:22.179 -----------------------------------------------
eclipse.buildId=unknown
java.version=9.0.1
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=de_DE
Command-line arguments:  -os win32 -ws win32 -arch x86_64

!ENTRY org.eclipse.osgi.compatibility.state.nl_fr 2 0 2018-01-07 18:10:26.963
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_fr [5]
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_ru 2 0 2018-01-07 18:10:26.978
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_ru [10]
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_uk 2 0 2018-01-07 18:10:26.978
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_uk [12]
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_tr 2 0 2018-01-07 18:10:26.978
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_tr [11]
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_it 2 0 2018-01-07 18:10:26.978
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_it [7]
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_hu 2 0 2018-01-07 18:10:26.978
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_hu [6]
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_pl 2 0 2018-01-07 18:10:26.978
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_pl [8]
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_ro 2 0 2018-01-07 18:10:26.978
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_ro [9]
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_es 2 0 2018-01-07 18:10:26.978
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_es [3]
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_de 2 0 2018-01-07 18:10:26.978
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_de [2]
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi.compatibility.state.nl_eu 2 0 2018-01-07 18:10:26.978
!MESSAGE Could not resolve module: org.eclipse.osgi.compatibility.state.nl_eu [4]
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state
  Unresolved requirement: Fragment-Host: org.eclipse.osgi.compatibility.state


!ENTRY org.eclipse.osgi 4 0 2018-01-07 18:10:26.978
!MESSAGE Anwendungsfehler
!STACK 1
org.eclipse.e4.core.di.InjectionException: java.lang.NoClassDefFoundError: javax/annotation/PostConstruct
	at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:410)
	at org.eclipse.e4.core.internal.di.InjectorImpl.make(InjectorImpl.java:318)
	at org.eclipse.e4.core.contexts.ContextInjectionFactory.make(ContextInjectionFactory.java:162)
	at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createDefaultHeadlessContext(E4Application.java:491)
	at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createDefaultContext(E4Application.java:505)
	at org.eclipse.e4.ui.internal.workbench.swt.E4Application.createE4Workbench(E4Application.java:204)
	at org.eclipse.e4.ui.internal.workbench.swt.E4Application.start(E4Application.java:149)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.base/java.lang.reflect.Method.invoke(Unknown Source)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1499)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1472)
Caused by: java.lang.NoClassDefFoundError: javax/annotation/PostConstruct
	at org.eclipse.e4.core.internal.di.InjectorImpl.inject(InjectorImpl.java:124)
	at org.eclipse.e4.core.internal.di.InjectorImpl.internalMake(InjectorImpl.java:399)
	... 19 more
Caused by: java.lang.ClassNotFoundException: javax.annotation.PostConstruct cannot be found by org.eclipse.e4.core.di_1.6.100.v20170421-1418
	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:433)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:395)
	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:387)
	at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:150)
	at java.base/java.lang.ClassLoader.loadClass(Unknown Source)
	... 21 more

Hat jemand einen Tipp für mich wie ich Fakturama erfolgreich unter Windows 7 betreiben kann?

Vielen Dank im Voraus und viele Grüße,

Hilipina
Re: Eclipse-Probleme
07. Januar 2018 20:20
Hallo Hilipina,

versuche es mal mit einem Downgrade auf Java 8.

Viel Erfolg
Nicole
Re: Eclipse-Probleme
07. Januar 2018 21:39
Vielen Dank Nicole,

ich bin durch den Downgrade auf Java 8 schonmal einen Schritt weitergekommen. Er hat mir das Migrationsfenster geöffnet. Konnte das auch alles abschließen. Er wollte Fakturama neu starten. Hat es aber nicht gemacht. Win neugestartet und nochmals versucht Fakturama zu öffnen. Er zeigt mir jetzt nur noch das Startbild an und dann nichts mehr. Im Task Manager ist Fakturama auch nicht aufgeführt.

Mh, installiere es nocheinmal neu. Alle guten Dinge sind drei. smiling smiley

Einen schönen Abend wünsche ich.
Re: Eclipse-Probleme
07. Januar 2018 22:14
Bitte vor der Neuinstallatioin im Nutzerverzeichnis das Verzeichnis .fakturama2 löschen.

Viele Grüße,
Ralf.
Re: Eclipse-Probleme
09. Januar 2018 14:01
Vielen herzlichen Dank, es funktioniert jetzt.

Viele Grüße,
Nina
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen