Ubuntu 17.10 - Probleme und Workaround

geschrieben von dererik 
Willkommen! Anmelden Ein neues Profil erzeugen Suche
Ubuntu 17.10 - Probleme und Workaround
19. November 2017 11:17
Hallo,

nach Update auf Ubuntu 17.10 ging Fakturama nicht mehr, merkwürdigerweise keine Dateien mehr da etc.

Habe dann Fakturama versucht neu zu installieren, nix,

terminal: java - version
open-jdk 9

hm

alles deinstalliert (java), jdk 8 neu installiert und fakturama so installiert:

(https://4noobs.de/viewtopic.php?t=51)

dpkg -i Installer_Fakturama_linux_64Bit_1_6_9c.deb

meckert dann über unerfüllte Abhängigkeiten, aber läuft!


Ich habe kein

apt-get -f install

laufen lassen!


vielleicht hilft es ja dem einen oder anderen, Ubuntu scheint Java auf jdk9 upzudaten, was dann, zumindest bei mir, nicht funzt, ach ja hatte auch Oracle Java ausprobiert - no!

einen schönen Sonntag
wünscht
erik
Re: Ubuntu 17.10 - Probleme und Workaround
19. November 2017 14:33
Hallo Erik,
danke für den Tip. Java 9 ist derzeit tatsächlich nicht geeignet für Fakturama, aber Oracle JDK 8 sollte funktionieren.

Viele Grüße,
Ralf.
Re: Ubuntu 17.10 - Probleme und Workaround
24. November 2017 10:07
..doch keine gute Idee..

bei meiner Version oben bleiben unerfüllte Abhängigkeiten (ohne install -f) - wenn das läuft schmeißt der Prozess fakturama wieder runter - mit Fakturama hängt apt mit unerfüllten Abhängigkeiten.

mit Oracle Java 8:

sudo dpkg -i Installer_Fakturama_linux_64Bit_1_6_9c.deb
Vormals nicht ausgewähltes Paket fakturama wird gewählt.
(Lese Datenbank ... 312662 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von Installer_Fakturama_linux_64Bit_1_6_9c.deb ...
Entpacken von fakturama (1.6.9c) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von fakturama:
fakturama hängt ab von libreoffice | openjdk; aber:
Paket libreoffice ist nicht installiert.
Paket openjdk ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes fakturama (--install):
Abhängigkeitsprobleme - verbleibt unkonfiguriert
Trigger für bamfdaemon (0.5.3+17.10.20170810-0ubuntu1) werden verarbeitet ...
Rebuilding /usr/share/applications/bamf-2.index...
Trigger für desktop-file-utils (0.23-1ubuntu3) werden verarbeitet ...
Trigger für gnome-menus (3.13.3-6ubuntu5) werden verarbeitet ...
Trigger für mime-support (3.60ubuntu1) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
fakturama


Ideen?

danke und gruss
erik
Re: Ubuntu 17.10 - Probleme und Workaround
24. November 2017 10:18
Hallo Erik,

das steht doch noch
Zitat

Paket libreoffice ist nicht installiert.
Paket openjdk ist nicht installiert.

Das müßtest Du noch mit installieren. Oder paßt da bloß die Version nicht? Dann müßte ich das im Installer anpassen. Ansonsten geht auch ein tar.gz (kann ich liefern), das brauchst Du bloß irgendwo auspacken.

Viele Grüße,
Ralf.
Re: Ubuntu 17.10 - Probleme und Workaround
24. November 2017 10:58
Hallo Ralf,

danke für die schnelle Antwort -

libreoffice ist installiert, openjdk auch, deshalb ??

vielleicht ist mein Rechner auch schon zu verbastelt


Das tar wäre prima!

danke und gruss
erik
Re: Ubuntu 17.10 - Probleme und Workaround
24. November 2017 12:53
Das TAR gibt's hier: [files.fakturama.info].

Viele Grüße,
Ralf.
Re: Ubuntu 17.10 - Probleme und Workaround
24. November 2017 14:42
Hallo Ralf,

danke, startet, importiert etc aber beim Drucken:

Java VM: Java HotSpot(TM) 64-Bit Server VM (25.151-b12 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C [libgdk-x11-2.0.so.0+0x4e73c] gdk_display_open+0x5c
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /home/erik/fakturama/fak_nov_2017/Fakturama_linux.gtk.x86_64_2.0.0-RC8/hs_err_pid13237.log
#
# If you would like to submit a bug report, please visit:
# [bugreport.java.com]
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.


hier das error Log

gruss
erik
Re: Ubuntu 17.10 - Probleme und Workaround
24. November 2017 19:13
Hm. Das ist wieder mal einer dieser üblen Gtk-Fehler unter Linux. Ich dachte, wir hätte schon alle eingesammelt... Ich check das mal.

Viele Grüße,
Ralf.
Re: Ubuntu 17.10 - Probleme und Workaround
24. November 2017 19:23
Geh mal bitte in ein Terminal und gib folgendes ein:
export SWT_GTK3=0
/usr/share/fakturama2/Fakturama -clean

Das ganze hängt mit diesem Bug zusammen.

Du kannst auch vorher noch
apt-get install libwebkitgtk-1.0-0

ausführen, das hat bei mir auch bei manchen Konstellationen geholfen.

In dem Bug steht auch noch
Zitat

please upgrade the glibc version to 2.14

Kannst Du checken, welche Version diese Bibliothek bei Dir hat?

In Deiner usr/share/fakturama2/Fakturama.ini kannst Du vor vmargs noch folgendes einfügen:
--launcher.GTK_version
2
Sorry für diese Bastelei, aber es ist halt manchmal etwas kompliziert...

Viele Grüße,
Ralf.
Re: Ubuntu 17.10 - Probleme und Workaround
24. November 2017 19:54
Hallo Ralf,

danke schön, so gehts!


GLIB

erik@erik-ThinkPad-T420:/usr/share$ ldd --version
ldd (Ubuntu GLIBC 2.26-0ubuntu2) 2.26

..komisch ..

vielen Dank für die Mühe und die viele Arbeit - gutes Programm!

gruss
erik
Re: Ubuntu 17.10 - Probleme und Workaround
03. Dezember 2017 11:56
Hallo Ralf,

jetzt ist es wieder kaputt, beim Drucken:

################################################

(Fakturama:4380): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplayManager'

(Fakturama:4380): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(Fakturama:4380): GLib-GObject-CRITICAL **: g_object_new_with_properties: assertion 'G_TYPE_IS_OBJECT (object_type)' failed

(Fakturama:4380): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(Fakturama:4380): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(Fakturama:4380): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(Fakturama:4380): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(Fakturama:4380): GLib-GObject-WARNING **: cannot register existing type 'GdkDisplay'

(Fakturama:4380): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(Fakturama:4380): GLib-GObject-CRITICAL **: g_type_register_static: assertion 'parent_type > 0' failed

(Fakturama:4380): GLib-CRITICAL **: g_once_init_leave: assertion 'result != 0' failed

(Fakturama:4380): GLib-GObject-CRITICAL **: g_object_new_with_properties: assertion 'G_TYPE_IS_OBJECT (object_type)' failed
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007f4c7505873c, pid=4380, tid=0x00007f4d6ace8700
#
# JRE version: Java(TM) SE Runtime Environment (8.0_151-b12) (build 1.8.0_151-b12)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.151-b12 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C [libgdk-x11-2.0.so.0+0x4e73c] gdk_display_open+0x5c
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /usr/share/fakturama2/hs_err_pid4380.log
#
# If you would like to submit a bug report, please visit:
# [bugreport.java.com]
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

############################################

glib

erik@erik-ThinkPad-T420:/usr/share/fakturama2$ sudo apt-cache show libc6
Package: libc6
Architecture: amd64
Version: 2.26-0ubuntu2
Multi-Arch: same
Priority: required
Section: libs
Source: glibc
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: GNU Libc Maintainers <debian-glibc@lists.debian.org>
Bugs: [bugs.launchpad.net]
Installed-Size: 11389
Depends: libgcc1
Suggests: glibc-doc, debconf | debconf-2.0, locales
Breaks: hurd (<< 1:0.5.git20140203-1), libtirpc1 (<< 0.2.3), locales (<< 2.26), locales-all (<< 2.26), nscd (<< 2.26)
Replaces: libc6-amd64
Filename: pool/main/g/glibc/libc6_2.26-0ubuntu2_amd64.deb
Size: 2777762
MD5sum: f33ebbfb177b9e072fec0ab07d480dbe
SHA1: 2887712cd26956310e65a1a481ea0007bb87f505
SHA256: d42d424e72a9059bd00a89445d1af319caa4aee5eaf8f80636b2b3117ea475b3
Homepage: [www.gnu.org]
Description-de: GNU C-Bibliothek: Dynamische Bibliotheken
Enthält die Standardbibliotheken, die von nahezu allen Programmen im
System verwendet werden. Dieses Paket enthält dynamische Versionen der
Standard-C-Bibliothek und der Standard-Math-Bibliothek, sowie vieler
anderer.
Description-md5: fc3001b0b90a1c8e6690b283a619d57f
Task: minimal
Supported: 9m



auf dem Rechner hat sich mE nix verändert...

danke und gruss
erik
Re: Ubuntu 17.10 - Probleme und Workaround
03. Dezember 2017 18:19
Bingo!

export SWT_GTK3=0
/usr/share/fakturama2/Fakturama -clean


und bei Einstellungen / Office Integration nur als .odt

funktioniert!

gruss
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen