modified Shop execute 196 Fehlermeldung

geschrieben von zelda 
Willkommen! Anmelden Ein neues Profil erzeugen Suche
modified Shop execute 196 Fehlermeldung
11. Juli 2019 13:44
Guten Tag,

ich habe die modified Shopsoftware auf meiner website mit einem Testkunden, einem Testartikel installiert. Die Anmeldung als Admin funktioniert über einen Webbrowser ohne Probleme. Also:

[xyzshop.de] -> die Anmeldemaske des shops erscheint
--> Eingabe der adminEmail und dem Passwort öffnet den Administrator Modus des shops

Die Connector Datei fakturama_connector.php für den modiefied Shop heruntergeladen und in den ordner /admin via Filezilla hochgeladen....gleiche Rechte wie alle anderen php Dateien 0644

In fakturama 2.0.4 unter Webshop folgenden Eintrag gemacht:

Webshop URL: [xyzshop.de]
Benutzername: adminEmail
Passwort: admin Passwort

In der Webshop-Anmeldung keine Anmeldung aktiviert (aber als Lösungsversuch auch 1x mit gleicher admin Anmeldung als Eintrag Versehen)

Beim Webshop-Abruf erscheint das Fenster:

Fehler beim Import aus Webshop Fehler beim Verbinden mit dem Webserver


Im Logfile wird folgendes eingetragen:

!SESSION 2019-07-11 13:02:07.049 -----------------------------------------------
eclipse.buildId=2.0.4.
java.version=1.8.0_161
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=de_DE
Command-line arguments: -os win32 -ws win32 -arch x86_64

!ENTRY com.sebulli.fakturama.common 4 0 2019-07-11 13:04:11.135
!MESSAGE c.s.f.w.WebShopImportManager.execute:196|Fehler beim Verbinden mit dem Webserver. confused smileysad smiley

Vielen Dank im Voraus für jegliche Hinweise zur Lösung des Problems, da ich sehr gerne die Verknüpfung zum Webshop nutzen möchte. eye rolling smiley
Re: modified Shop execute 196 Fehlermeldung
15. Juli 2019 17:18
....ich habe jetzt einmal zum Ausschlußverfahren von Fehlern (bei nur einer Shop Installation) die zwei anderen Shops, von denen für die fakturama 2.x Version connectoren zum download vorliegen ebenfalls testweise auf meinem WEBserver installiert.

shop 1 also mein gewünschter shop 'modified eCommerce'
shop 2 der xtCommerce shop
shop 3 der osCommerce shop

Alle drei shops sind solo über meine Web ohne Fehlermeldung aufrufbar, sowohl als Testkunde, als auch über das admin Portal. Shop 2+3 enthalten allerdings nur die bei der Installation möglichen Demo Daten.

Hier das Ergebnis der .log Datei im .fakturama2 Ordner bei den einzelnen WEBSHOP Verbindungsaufrufen:

!SESSION 2019-07-15 16:37:09.828 -----------------------------------------------
eclipse.buildId=2.0.4.
java.version=1.8.0_161
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=de_DE
Command-line arguments: -os win32 -ws win32 -arch x86_64

!ENTRY com.sebulli.fakturama.common 4 0 2019-07-15 16:37:45.080
!MESSAGE c.s.f.w.WebShopImportManager.execute:196|Fehler beim Verbinden mit dem Webserver.

!ENTRY com.sebulli.fakturama.common 4 0 2019-07-15 16:43:02.428
!MESSAGE c.s.f.w.WebShopImportManager.execute:196|Fehler beim Öffnen von:
meinewebxyz.de/shop2/xtCommerce/fakturama_connector_xtc4.php
Message: unerwartetes Element (URI:"", lokal:"br" ). Erwartete Elemente sind ,,

Trace: com.sun.xml.internal.bind.v2.runtime.unmarshaller.UnmarshallingContext.handleEvent(Unknown Source)


!ENTRY com.sebulli.fakturama.common 4 0 2019-07-15 16:47:36.014
!MESSAGE c.s.f.w.WebShopImportManager.execute:196|Fehler beim Öffnen von:
meinewebxyz.de/shop3/catalog/admin/fakturama_connector.php
Message: unerwartetes Element (URI:"", lokal:"webshopexport" ). Erwartete Elemente sind ,,

Trace: com.sun.xml.internal.bind.v2.runtime.unmarshaller.UnmarshallingContext.handleEvent(Unknown Source)




Die Fehlermeldungen von shop 2+3 unterscheiden sich komplett vom shop 1 (dem modified eCommerce). Wie man sehen kann ist beim shop 1 eine VERBINDUNG unmöglich (wie oben erwähnt, funktioniert der Zugang aber über jeden Webbrowser) und bei den anderen beiden Testshops ist eine Verbindung möglich, nur beim Öffnen werden der Meldung nach wohl im Connector 'noch' falsche Parameter stecken.

Leider kann ich beim shop 1 am URL Aufruf nichts verändert ausprobieren (meinshopxyz.de/shop1/shoproot/admin/fakturama_connector.php), denn die fakturama_connector.php muss ja gestartet werden eye popping smileyeye rolling smileyconfused smiley
Ein schnell zu übersehender Flüchtigkeitsfehler beim Shop Connect
17. Juli 2019 12:32
Ein persönlicher Hinweis für schnell verwechselbare downloads des connectors für den modified eCommerce shop. Wer so wie ich noch Nutzer der 'alten Supportseite' (://supr.com/fakturama/) von fakturama war, jetzt kann man ja sowieso nichts mehr downloaden, kann es leicht übersehen, weil die Versionsnummern flüchtig betrachtet identisch sind.

Auf der alten Seite wurde explizit zwischen den Versionen des modified Shops 1.06 und 2.04 unterschieden. Jeder kennt die Versionsangaben bei Grafiktreibern etc. ....die Ziffer Null bei den Treiberversionen wird häufig in den download Ordnern als Versionsangabe nicht erwähnt, oder nur ein Teil der gesamten Versionsnummer notiert.
So hatte ich im Kopf (eingebrannt)smoking smiley....von Fakturama gibt es die Version 1.x6 und 2.x4.

Auf der jetzt aktuellen Supportseite von Fakturama (//dms.fakturama.info/) steht zum download auch eine download Version 1.x und 2.x zur Verfügung. Hier hier handelt es sich aber NUR um die Fakturama Version. Es wird ja auch korrekt so bezeichnet, allerdings erfährt man nur im Deklarationsteil der fakturama_connector.php Datei, dass es sich bei der Version 2.x um den Connector for Fakturama 2.x aber noch um den 'alten' modified Shop Version 1.06 handelt.cool smiley

Da ich mit dem shop erst neu starte, habe ich natürlich automatisch die shopversion 2.04 die seit 2017 als stable Version existiert installiert....eine Installation der alten shop-Version ist bei meinem Provider-Account eh kompliziert, weil dort offiziell die PHP Version 7.1 aktiv ist....ich kann dort zwar auf PHP 5.6 generell umstellen aber nur umständlich versuchen diese ältere Version für nur einen webordner zu aktivieren.

Insofern habe/hatte ich natürlich meine shopanbindung erst einmal mit dem falschen fakturama connector versucht.

Die 'Proforma' Version des in Bearbeitung befindlichen neuen fakturama_connectors für die Version Fakturama 2.x und mod Shop 2.x habe ich jetzt natürlich auch im Forum gefunden (zu erkennen an dem facturama Namen der php-Datei. Im Deklarationsteil der php Datei wird dort auch die Überarbeitung vom 2018-02-07 eingetragen.

Für die Verbindung zum mod shop Version 2.0.4 bleibt es bei mir allerdings nach wie vor bei der Fehlermeldung:

!ENTRY com.sebulli.fakturama.common 4 0 2019-07-16 13:27:04.605
!MESSAGE c.s.f.w.WebShopImportManager.execute:196|Fehler beim Verbinden mit dem Webserver.
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen