Angebot kann nicht erstellt werden

geschrieben von MOS6581 
Willkommen! Anmelden Ein neues Profil erzeugen Suche
Angebot kann nicht erstellt werden
01. Juli 2019 15:01
Hallo Beisammen,

ich habe ein großes Angebot, welches ich vorher ausgedruckt hatte, danach ein paar Änderungen eingefügt habe (div. Positionen verändert und neue sind hinzugekommen).

Nun kommt, wenn ich das Angebot Drucken bzw. in LibreOffice öffnen möchte die Fehlermeldung:

"Dokument konnte nicht erstellt werden. Bitte prüfen Sie den OpenOffice-Pfad und den Ausgabepfad!"

Mit anderen Angeboten funktioniert es einwandfrei, LibreOffice-Geisterthreads sind im Task Manager auch keine zu sehen. Folgenden Auszug aus dem Log habe ich noch:

Zitat

!ENTRY com.sebulli.fakturama.common 4 0 2019-07-01 14:58:06.176
!MESSAGE Document couldn't be created. Reason: Error starting OpenOffice with Document.ott
!STACK 0
com.sebulli.fakturama.exception.FakturamaStoringException: Error starting OpenOffice with Document.ott
at com.sebulli.fakturama.office.OfficeDocument.createDocument(OfficeDocument.java:330)
at com.sebulli.fakturama.handlers.CreateOODocumentHandler.openOODocument(CreateOODocumentHandler.java:421)
at com.sebulli.fakturama.handlers.CreateOODocumentHandler.access$0(CreateOODocumentHandler.java:391)
at com.sebulli.fakturama.handlers.CreateOODocumentHandler$1.handleEvent(CreateOODocumentHandler.java:211)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:86)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4428)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4238)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3817)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1150)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1039)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:153)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.start(E4Application.java:162)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.base/java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
at org.eclipse.equinox.launcher.Main.run(Main.java:1499)
at org.eclipse.equinox.launcher.Main.main(Main.java:1472)

!ENTRY com.sebulli.fakturama.common 4 0 2019-07-01 14:58:06.199
!MESSAGE Exception occured:
!STACK 0
java.lang.NullPointerException
at com.sebulli.fakturama.office.OfficeDocument.fillItemTableWithData(OfficeDocument.java:1076)
at com.sebulli.fakturama.office.OfficeDocument.fillItemTableWithData(OfficeDocument.java:805)
at com.sebulli.fakturama.office.OfficeDocument.createDocument(OfficeDocument.java:292)
at com.sebulli.fakturama.handlers.CreateOODocumentHandler.openOODocument(CreateOODocumentHandler.java:421)
at com.sebulli.fakturama.handlers.CreateOODocumentHandler.access$0(CreateOODocumentHandler.java:391)
at com.sebulli.fakturama.handlers.CreateOODocumentHandler$1.handleEvent(CreateOODocumentHandler.java:211)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:86)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4428)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1079)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4238)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3817)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1150)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1039)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:153)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application.start(E4Application.java:162)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.base/java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
at org.eclipse.equinox.launcher.Main.run(Main.java:1499)
at org.eclipse.equinox.launcher.Main.main(Main.java:1472)

Kann hier jemand weiterhelfen? Wie gesagt, mit anderen Angeboten und auch Rechnungen etc. funktioniert es. Eine zweite Dokumentvorlage habe ich ebenfalls ausprobiert.

Danke und LG,
MOS
Re: Angebot kann nicht erstellt werden
01. Juli 2019 23:35
Moin,
sieht aus, als ob es irgendwas mit den Produktbildern zu tun hätte. Ich kann's aber noch nicht richtig erklären. Kannst Du mal testweise den Platzhalter für das Image entfernen?

Viele Grüße,
Ralf.
Re: Angebot kann nicht erstellt werden
02. Juli 2019 08:19
Moin Ralf,

tatsächlich - Platzhalter entfernt und das Angebot wird korrekt ausgegeben smiling smiley
Ich schaue nachher mal, ob ich bei irgendeiner der neu hinzugefügten Positionen ein anderes Dateiformat / utopische Bildgröße verwendet habe, vielleicht hilft das beim Debugging.

Danke schon mal für die schnelle Hilfe!

Viele Grüße,
MOS
Re: Angebot kann nicht erstellt werden
02. Juli 2019 08:27
Hallo noch mal,

ich konnte den Bug gerade nachvollziehen. Ich hatte eine Position im Angebot, bei der Text in den Spalten Artikelnummer, Bild und Name steht, aber keine Beschreibung. Ich habe händisch eine Beschreibung hinzugefügt und das Angebot wird korrekt erstellt.

Wär' ich erst mal nicht darauf gekommen, da manuell erstellte Positionen über das Plus-Zeichen auch ohne Beschreibung auskommen.
Kann ich dir hier irgendwie mit DB-Dumps o.ä. weiterhelfen?

Viele Grüße,
Daniel
Re: Angebot kann nicht erstellt werden
02. Juli 2019 10:27
Besten Dank für die Info. Ich denke, das reicht mir erst mal zur Fehlerbehebung, ist ja schon ziemlich eingegrenzt. Hab dafür mal einen Bugeintrag erstellt.

Viele Grüße,
Ralf.
Re: Angebot kann nicht erstellt werden
02. Juli 2019 10:30
Klasse!
Wenn du noch etwas von mir brauchst, einfach Bescheid sagen! smiling smiley

Viele Grüße,
Daniel
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen