[Fehler] Artikel defekt (kann nicht auf Rechnung eingefügt werden) org.eclipse.e4.core.di.InjectionException: java.lang.NullPointerException

geschrieben von eek6smxf 
Willkommen! Anmelden Ein neues Profil erzeugen Suche
Hallo zusammen,

ich habe einen (reproduzierbaren) Fehler gefunden!

Zitat
Fehlermeldung
org.eclipse.e4.core.di.InjectionException: java.lang.NullPointerException
java.lang.NullPointerException

Erstelle ich ein Dokument und füge eine ("defekten'') Artikel hinzu, kommt es zu der Fehlermeldung.

Öffne ich die Artikelliste ist "alles ok" und da inkl. Beschreibung.

Öffne ich den Artikel um ihn zu bearbeiten fehlt die Hälfte!

Artikelnummer noch vorhanden
Name          noch vorhanden
Kategorie (keine Ahnung, hatte ich nicht angegeben)
GTIN (keine Ahnung, hatte ich nicht angegeben)
Beschreibung fehlt!
Einheit fehlt!
ab Stückzahl noch vorhanden Preis noch vorhanden
ab Stückzahl  noch vorhanden Preis noch vorhanden
ab Stückzahl  noch vorhanden Preis fehlt, aber auch das komplette Feld ist weg!

Was mit noch auffällt:
Die Ganze Eingabemaske reagiert dann nicht mehr richtig. Fakturama stellt (mit Ausnahme des Artikelnummernfeldes) keinerlei Änderungen der übrigen Felder fest. Erst wenn die Artikelnummer verändert wird, kommt der "Stern" (speichern), allerdings bleibt dieser dann auch da ... man kann nichts speichern. (will man vermuutlich ja auch gar nicht, weil ja eh die Hälfte "defekt" ist)

Wie kommt es zu dem Fehler?
- man erstelle einen Artikel inkl. allem zipp und zapp
- Preis für 2 Stück
- Preis für 3 Stück
- Preis für 4 Stück

Wie man sieht fange ich ab 2 Stück an (hat s/einen Grund), aber das ist erstmal nicht das Problem

Dann ist mir eingefallen "3 Stück" ist eher suboptimal, da ja meist immer 2 Stück gebraucht werden, also habe ich aus der 3 eine 4 gemacht, den Preis von den 4 Stück da eingesetzt und gelöscht.

Scheisse, das hat jetzt schon 2x so "geklappt", jetzt nicht mehr. Werde das noch herausbekommen, was den Fehler genau auslöst.

Das hier löst den Fehler aus ...
Dann habe ich die "zweiten 4 Stück" also die 4 gelöscht und gespeichert ... patsch!

Neuer Test : Habe nun die 3. Preisstufe (nutze nur 3 Stück) gelöscht und auch den Preis "gelöscht" (es bleibt eine Null zurück) und auch in diesem Fall für der Artikel "zerstört" - es muss also zwangsläufig eine Zahl bei Stück verbleiben - egal ob man "will oder nicht".

Das sollte besser geändert werden. Oder? winking smiley

Hier mal wie das dann aussieht:



Viele Grüße!


……eek

Dein Problem wurde gelöst? Super, dann markiere doch bitte dein Thema als ERLEDIGT.
Wie das geht, kannst du hier nachlesen! (Kurzanleitung: [erledigt] vorn im Betreff einfügen)




4-mal bearbeitet. Zuletzt am 30.05.19 16:10.
Moin,
danke für die gute Beschreibung. Da scheint was mit den Staffelpreisen nicht zu funktionieren. Ich seh's mir an.
Bug 773.

Viele Grüße,
Ralf.



1-mal bearbeitet. Zuletzt am 31.05.19 23:23.
rheydenr schrieb:
-------------------------------------------------------
>
> B
> ug 773
.

Top! thumbs up Danke


Viele Grüße!


……eek

Dein Problem wurde gelöst? Super, dann markiere doch bitte dein Thema als ERLEDIGT.
Wie das geht, kannst du hier nachlesen! (Kurzanleitung: [erledigt] vorn im Betreff einfügen)
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen