Fakturama läss sich nicht starten

geschrieben von Alfred 
Willkommen! Anmelden Ein neues Profil erzeugen Suche
Fakturama läss sich nicht starten
22. März 2019 16:45
Nach erfolgter Installation bekam ich die Aufforderung Java RE Version 6 wiederherzustellen mit weiterführendem Link. Nach erfolgter Ausführung und erneutem Startversuch eine Fehlermeldung. Benutztes osX 10.14.3
LogfileEintrag:

!SESSION Fri Mar 22 16:28:20 GMT+01:00 2019 ------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2019-03-22 16:28:20.045
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.UnsupportedClassVersionError: org/eclipse/core/runtime/adaptor/EclipseStarter : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:650)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
at org.eclipse.equinox.launcher.Main.run(Main.java:1499)

Habe danach java komplett deinstalliert und neu aufgesetzt, daraufhin Aufforderung die ältere RE-Version 6 wiederherzustellen. Gemacht, getan Ergebnis siehe Anfang.
Und nun?



1-mal bearbeitet. Zuletzt am 22.03.19 16:50.
Re: Fakturama läss sich nicht starten
22. März 2019 18:24
Hallo Alfred,
leider lügt Dein Mac hier smiling smiley Du brauchst nämlich mindestens Java 8. Ich habe leider noch nicht herausgefunden, warum MacOS behauptet, daß Fakturama Java 6 braucht. Evtl. hilft DIr auch dieser Beitrag weiter.

Viele Grüße,
Ralf.
Re: Fakturama läss sich nicht starten
22. März 2019 23:46
Vielen Dank für Deine Bemühung..
Nachdem ich den Mac nochmal von allem Java gereinigt habe und danach zuerst Java JDK passend zur JRE Version und dann die JRe Version installiert habe ( ...ist ein wenig aufwendig das auf der Java Seite rauszufummeln), wollte ich eigentlich den o.g. workaround machen, habe aber erstmal fakturama2 gestartet und siehe da, jetzt läufts!

Grüße Alfred

PS. Beim Querlesen des Forums in der Zwischenzeit ist mir aufgefallen, daß Java Probleme häufiger von unterschiedlichen Nutzern thematisiert wurden. Vielleicht wäre es sinnvoll Java Problemen einen eigenen Topic zu geben und den Kram an dieser Stelle zu bündeln.
Re: Fakturama läss sich nicht starten
09. Juni 2019 16:54
Hallo zusammen.
Bin neu hier und habe evtl. ein ähnliches Problem:

Gemäss der Anleitung (zuerst V1.6.9 installieren) will ich Fakturama 2 installieren auf meinem OSX 10.14.5. Was jedoch nicht funktioniert. V1.6.9 lässt sich problemlos starten und bedienen. Beim Startversuch von Fakturama 2 jedoch kommt die Meldung:
"An error has occured. See the logfile."

Im Logfile steht:

!SESSION Sun Jun 09 15:23:02 GMT+01:00 2019 ------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2019-06-09 15:23:02.104
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.UnsupportedClassVersionError: org/eclipse/core/runtime/adaptor/EclipseStarter : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:650)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
at org.eclipse.equinox.launcher.Main.run(Main.java:1499)


Leider kann ich aus diesem Logfile nicht erruieren, was das Problem ist.
Java ist auf V8u211 aktualisiert.

Kann mir jemand hierbei unterstützen?

Danke Euch jetzt schon mal..
Re: Fakturama läss sich nicht starten
09. Juni 2019 17:08
Moin,
das Problem ist hier tatsächlich wieder mal die Java-Version. Irgendwo geistert auf Deinem System noch eine alte Version herum, die beim Starten verwendet wird. Kannst Du bitte mal den oben beschriebenen Workaround ausprobieren? Ich bin noch nicht dahintergekommen, wie die Java-Versionen beim Mac verwaltet werden.

Viele Grüße,
Ralf.
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen