2.0.1: kein PDF

geschrieben von Etcetera 
Willkommen! Anmelden Ein neues Profil erzeugen Suche
2.0.1: kein PDF
19. März 2018 20:19
Hallöchen,

beim "Drucken" mit 2.0.1 wird bei mir nur ein ODT, kein PDF erstellt (in den Einstellungen ist beides gewählt). Eine Fehlermeldung erscheint nur, wenn das automatische Öffnen des PDFs gewählt ist.

In .fakturama2/.metadata/.log findet sich dazu dies (Dateiname durch Austausch von alphabetischen Zeichen durch @ unleserlich gemacht):
!ENTRY com.sebulli.fakturama.common 4 0 2018-03-19 19:39:03.020
!MESSAGE Dokument konnte nicht erstellt werden! Grund: Error starting OpenOffice with 1800098_@@@@@@@-@@@@@@@@@@@_@@@@@@@_GmbH,_@@@@@@_@@@@@@.odt
!STACK 0
com.sebulli.fakturama.exception.FakturamaStoringException: Error starting OpenOffice with 1800098_@@@@@@@-@@@@@@@@@@@_@@@@@@@_GmbH,_@@@@@@_@@@@@@.odt
	at com.sebulli.fakturama.office.OfficeDocument.createDocument(OfficeDocument.java:319)
	at com.sebulli.fakturama.handlers.CreateOODocumentHandler.openOODocument(CreateOODocumentHandler.java:290)
	at com.sebulli.fakturama.handlers.CreateOODocumentHandler.access$0(CreateOODocumentHandler.java:270)
	at com.sebulli.fakturama.handlers.CreateOODocumentHandler$1.handleEvent(CreateOODocumentHandler.java:220)
	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:86)
	at org.eclipse.swt.widgets.Display.sendEvent(Display.java:5348)
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1348)
	at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4602)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:4183)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1150)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1039)
	at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:153)
	at org.eclipse.e4.ui.internal.workbench.swt.E4Application.start(E4Application.java:162)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:498)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1499)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1472)

!ENTRY com.sebulli.fakturama.common 4 0 2018-03-19 19:39:03.020
!MESSAGE Exception occured: 
!STACK 0
java.lang.NullPointerException
	at sun.nio.fs.UnixPath.normalizeAndCheck(UnixPath.java:77)
	at sun.nio.fs.UnixPath.<init>(UnixPath.java:71)
	at sun.nio.fs.UnixFileSystem.getPath(UnixFileSystem.java:281)
	at java.nio.file.Paths.get(Paths.java:84)
	at com.sebulli.fakturama.office.OfficeDocument.createDocument(OfficeDocument.java:183)
	at com.sebulli.fakturama.handlers.CreateOODocumentHandler.openOODocument(CreateOODocumentHandler.java:290)
	at com.sebulli.fakturama.handlers.CreateOODocumentHandler.access$0(CreateOODocumentHandler.java:270)
	at com.sebulli.fakturama.handlers.CreateOODocumentHandler$1.handleEvent(CreateOODocumentHandler.java:220)
	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:86)
	at org.eclipse.swt.widgets.Display.sendEvent(Display.java:5348)
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1348)
	at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4602)
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:4183)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1150)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1039)
	at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:153)
	at org.eclipse.e4.ui.internal.workbench.swt.E4Application.start(E4Application.java:162)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:498)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1499)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1472)

Schöne Grüße
Etc



1-mal bearbeitet. Zuletzt am 20.03.18 20:20.
Re: 2.0.1: kein PDF
21. März 2018 09:11
Ergänzung und Workaround

Die LibreOffice-Version hier ist aktuell 5.1.6.2, installiert in /usr/lib/libreoffice, was so auch in den Fakturama-Einstellungen eingetragen war.

Ich habe nun einen Workaround gefunden, indem ich den Pfad auf ein altes LibreOffice 3.6 umgebogen habe, das ich aus Gründen der Kompatibilität zu alten StarOffice-Dateiformaten (die man bei LibreOffice ja leider schon seit längerem, und inzwischen auch bei OpenOffice über Bord geworfen hat) parallel auf dem System habe (irgendwann mal nach dieser Anleitung eingerichtet). Damit kriege ich jetzt auch wieder PDFs erstellt.

(Bei LibreOffice ist ja inzwischen die Version 6 aktuell, die ist aber über die Ubuntu-16.04-Paketquellen noch nicht zu bekommen. Wenn ich die habe – notfalls per LibreOffice-PPA –, werde ich nochmal berichten, ob sich damit was geändert hat.)

Grüße,
Etc



1-mal bearbeitet. Zuletzt am 21.03.18 09:12.
Re: 2.0.1: kein PDF
21. März 2018 09:24
Ok, damit erst mal Entwarnung: Mit LibreOffice 6.0.2.1 in /usr/lib/libreoffice klappt's jetzt auch wieder.

Grüßt:
Etc
Re: 2.0.1: kein PDF
21. März 2018 17:37
cool. Danke für die Rückmeldung.

Viele Grüße,
Ralf.
Re: 2.0.1: kein PDF
26. Mai 2018 23:11
Besten Dank! Bei mir hat es mit LibreOffice 6.0.4 für Windows 64bit dann auch wieder geklappt mit den PDF-Dateien.

Viele Grüße
winnewoerp
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen