Beta 5 OS X 10.9

geschrieben von stagprom 
Willkommen! Anmelden Ein neues Profil erzeugen Suche
Beta 5 OS X 10.9
23. Januar 2017 14:01
Hallo,

leider kann ich weder Beta 4 noch Beta 5 unter OS X 19.9 starten.
Es erscheint kurz das Logo und dann eine Fehlermeldung mit verweis auf das Logfile.
Bei der Beta 5 passierte am Anfang gar nichts, erst als ich Fakturama.app/Contents/MacOS/fakturama auf execute (chmod +x)
gesetzt habe erhielt ich das gleiche Verhalten wie Beta 4.
Anfang des log:

Zitat

!SESSION 2017-01-23 12:52:36.563 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_80
java.vendor=Oracle Corporation
BootLoader constants: OS=macosx, ARCH=x86_64, WS=cocoa, NL=de_DE
Framework arguments:  -keyring /Users/mm/.eclipse_keyring
Command-line arguments:  -os macosx -ws cocoa -arch x86_64 -keyring /Users/mm/.eclipse_keyring

!ENTRY org.eclipse.gemini.dbaccess.mysql 4 0 2017-01-23 12:52:37.485
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.gemini.dbaccess.mysql [696]
  Unresolved requirement: Import-Package: com.mysql.jdbc.jdbc2.optional; version="[5.0.0,6.0.0)"
    -> Export-Package: com.mysql.jdbc.jdbc2.optional; bundle-version="5.1.38"; bundle-symbolic-name="com.mysql.jdbc"; version="5.1.38"; uses:="com.mysql.jdbc,com.mysql.jdbc.log,javax.naming,javax.sql,javax.transaction.xa"
       com.mysql.jdbc [40]
         Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.8))"
  Unresolved requirement: Import-Package: com.mysql.jdbc; version="[5.0.0,6.0.0)"
    -> Export-Package: com.mysql.jdbc; bundle-version="5.1.38"; bundle-symbolic-name="com.mysql.jdbc"; version="5.1.38"; uses:="com.mysql.jdbc.log,javax.naming,javax.net.ssl,javax.xml.transform,org.xml.sax"

	at org.eclipse.osgi.container.Module.start(Module.java:444)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1600)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY com.mysql.jdbc 4 0 2017-01-23 12:52:38.127
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: com.mysql.jdbc [40]
  Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.8))"

	at org.eclipse.osgi.container.Module.start(Module.java:444)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY com.opcoach.e4.preferences 4 0 2017-01-23 12:52:38.138
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: com.opcoach.e4.preferences [41]
  Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di; bundle-version="1.3.0"
    -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.1.v20160712-0927"
       org.eclipse.e4.core.di [205]
         Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.8))"
         Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di.annotations; bundle-version="[1.4.0,2.0.0)"; visibility:="reexport"
           -> Bundle-SymbolicName: org.eclipse.e4.core.di.annotations; bundle-version="1.5.0.v20151127-1241"
              org.eclipse.e4.core.di.annotations [206]
                Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.8))"
  Unresolved requirement: Require-Bundle: org.eclipse.e4.core.services; bundle-version="1.1.0"
    -> Bundle-SymbolicName: org.eclipse.e4.core.services; bundle-version="2.0.100.v20160509-1032"; singleton:="true"
       org.eclipse.e4.core.services [241]
         Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
           -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.1.v20160712-0927"
  Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.model.workbench; bundle-version="1.0.0"
    -> Bundle-SymbolicName: org.eclipse.e4.ui.model.workbench; bundle-version="1.2.0.v20160229-1459"; singleton:="true"
       org.eclipse.e4.ui.model.workbench [327]
         Unresolved requirement: Require-Bundle: org.eclipse.e4.core.contexts; bundle-version="1.0.0"
           -> Bundle-SymbolicName: org.eclipse.e4.core.contexts; bundle-version="1.5.0.v20160504-0909"
              org.eclipse.e4.core.contexts [193]
                Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
                  -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.1.v20160712-0927"
         Unresolved requirement: Require-Bundle: org.eclipse.e4.core.services; bundle-version="0.9.0"
           -> Bundle-SymbolicName: org.eclipse.e4.core.services; bundle-version="2.0.100.v20160509-1032"; singleton:="true"
         Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di; bundle-version="1.0.0"
           -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.6.1.v20160712-0927"
  Unresolved requirement: Require-Bundle: org.eclipse.jface; bundle-version="3.9.0"
    -> Bundle-SymbolicName: org.eclipse.jface; bundle-version="3.12.0.v20160518-1929"; singleton:="true"
       org.eclipse.jface [713]
         Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.8))"

	at org.eclipse.osgi.container.Module.start(Module.java:444)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
	at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
	at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

.
.
.


Ideen?

Viele Grüße
Re: Beta 5 OS X 10.9
23. Januar 2017 20:39
Hallo stagprom,
welche Java-Version setzt Du ein? Es muß die Verison 8 sein.

Viele Grüße,
Ralf.
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen