Beta 5 startet nicht unter Ubuntu

geschrieben von kryger 
Willkommen! Anmelden Ein neues Profil erzeugen Suche
Beta 5 startet nicht unter Ubuntu
03. Januar 2017 20:38
Hallo, habe gestern fakturama entdeckt, als ich eine erp software suchte und einen Ersatz für die Lexware brauchte.

Ich wollte mir direkt die neuste beta ansehen, da ich auch eine Mehrplatzlösung brauche.
Leider bekomme ich die exe nicht ans laufen.
Ich habe Ubuntu 14.04lts und die Fakturama.v2.0.0b5-linux.gtk.x86_64 im Testverzeichnis entpackt, nach einem doppelklick suchte das System eine passende Software zum starten des Programms. In einem anderen Thread habe ich entdeckt, dass schonmal vergessen wurde die exe als ausführbare Datei zu kennzeichnen. OK in den Dateieigenschaften angeklickt und sie startete. :-)

Direkt danach kam leider die Fehlermeldung, dass das Programm eine logdatei erstellt hat.
Der Inhalt der Logdatei startet mit :

!SESSION 2017-01-03 20:18:43.923 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_121
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=de_DE
Command-line arguments: -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.gemini.dbaccess.mysql 4 0 2017-01-03 20:18:46.067
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.gemini.dbaccess.mysql [692]
Unresolved requirement: Import-Package: com.mysql.jdbc; version="[5.0.0,6.0.0)"
-> Export-Package: com.mysql.jdbc; bundle-version="5.1.38"; bundle-symbolic-name="com.mysql.jdbc"; version="5.1.38"; uses:="com.mysql.jdbc.log,javax.naming,javax.net.ssl,javax.xml.transform,org.xml.sax"
com.mysql.jdbc [40]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.8))"
Unresolved requirement: Import-Package: com.mysql.jdbc.jdbc2.optional; version="[5.0.0,6.0.0)"
-> Export-Package: com.mysql.jdbc.jdbc2.optional; bundle-version="5.1.38"; bundle-symbolic-name="com.mysql.jdbc"; version="5.1.38"; uses:="com.mysql.jdbc,com.mysql.jdbc.log,javax.naming,javax.sql,javax.transaction.xa"

at org.eclipse.osgi.container.Module.start(Module.java:444)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1600)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)


----
---
--
-- und endet nach ca 5800 ähnlichen Zeilen mit diesem:

!ENTRY org.eclipse.osgi 4 0 2017-01-03 20:18:47.419
!MESSAGE Anwendungsfehler
!STACK 1
java.lang.RuntimeException: Application "org.eclipse.e4.ui.workbench.swt.E4Application" could not be found in the registry. The applications available are: org.eclipse.equinox.app.error, org.eclipse.equinox.p2.garbagecollector.application, org.eclipse.equinox.p2.touchpoint.natives.nativePackageExtractor.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:248)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
at org.eclipse.equinox.launcher.Main.main(Main.java:1492)

- - - - - - - - Ende

Meine open-jdk version ist
java version "1.7.0_121"
OpenJDK Runtime Environment (IcedTea 2.6.8) (7u121-2.6.8-1ubuntu0.14.04.1)
OpenJDK 64-Bit Server VM (build 24.121-b00, mixed mode)

Macht das jetzt Sinn weiter irgendwie zu machen oder geht es generell nicht? was könnte fehlen? Ich bin auch relativ neu auf Ubuntu umgestiegen vor einem halben Jahr aus beruflichen Gründen und auf meinen Windows Rechner möchte ich eigentlich nichts mehr weiter installieren..

Besten Gruß, Kryger
PS: ich kann die logdatei gerne per email senden..
Re: Beta 5 startet nicht unter Ubuntu
03. Januar 2017 21:22
Hallo Kryger,
kannst Du vorsichtshalber nochmal Java 8 installieren und das damit testen? Ich habe die Linux-Version mal in einer VM getestet, weil ich kein natives System habe. Da hatte es glaube ich funktioniert.

Viele Grüße,
Ralf.
Re: Beta 5 startet nicht unter Ubuntu
04. Januar 2017 18:41
ich hatte das unter macOS auch, musste da erst die rechten setzen
Re: Beta 5 startet nicht unter Ubuntu
31. Januar 2017 21:27
nimm mal bitte Java 8, das ist das neueste, mit dem ich auch entwickelt habe.

Viele Grüße,
Ralf.
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen