Update unter Linux

geschrieben von admin_gerd 
Willkommen! Anmelden Ein neues Profil erzeugen Suche
Update unter Linux
16. Januar 2012 19:45
Will man unter Linux ein Update durchführen und wurde Fakturama unter Linux aus dem *.deb Paket installiert, so ist es notwendig, Fakturama mit Adminrechten zu starten.

im Terminal

sudo /usr/share/Fakturama/Fakturama

Fakturama frägt nach dem Arbeitsverzeichnis. Hier ein beliebiges, temporäres Verzeichnis angeben, dass später wieder gelöscht werden kann.

Im Menü Hilfe --> Check for Updates

Fakturama beenden.

Fakturama normal neu starten.
Re: Update unter Linux
17. Januar 2012 07:45
Hallo,

ich habe Debian drauf und Fakturama habe ich aus dem *.deb installiert.
Update von 1.5 auf 1.5.1, 1.5.2, 1.5.3 habe ganz einfach als user gemacht.
Also es ist ganz individuell was man wirklich drauf hat.

Gruß

Marek
Hannes
Re: Update unter Linux
26. Februar 2013 08:47
Hat super geklappt, danke.

gibt es auch eine Möglichkeit den Aufruf als su mit einem direkten Update zu verbinden?
Hintergrund wäre dann die Erstellung eines Scriptes, welches dies sozusagen automatisch macht und von relativen Laien auch durchführbar wäre.
Ein Handwerker wird sich kaum als su anmelden und dort das Update durchziehen.
(auch wenn es so scheint, als wenn hier Stillstand ist, habe ich ja die Hoffnung, dass es doch noch gepflegt wird. Wäre ja schad drum, so viel Arbeit und dann verkümmert in der Ecke)
karlos
Re: Update unter Linux
31. Juli 2013 15:30
Kann man ein Update auch manuell durchführen? Nutze momentan noch die Version 1.5.4 auf Ubuntu 12.04 und würde gerne auf 1.6.1 updaten. Leider funktioniert bei mir die oben beschriebene Vorgehensweise nicht. Ich erhalte folgende Fehlermeldung:

Some sites could not be found. See the error log for more detail.
No repository found at [code.google.com].
No repository found at [code.google.com].
Unable to read repository at [www.fakturama.org].
[www.fakturama.org] is not a valid repository location.

Viele Grüße!
Re: Update unter Linux
03. August 2013 21:18
Hallo karlos,
guck mal bei Einstellungen - Install / Update - Available Software Sites was da steht. Da muß es so einen Eintrag geben: [www.fakturama.org]
Die von Dir geposteten Links sahen so aus, also ob die direkt auf die Download-Seite zeigten. Das ist aber falsch.

Viele Grüße,
Ralf.
Re: Update unter Linux
26. September 2013 12:48
Ich möchte die neue Version installieren (aktuell installiert Fakturama V1.5.4 - 2012 unter Ubuntu 12.04LTS), aber Fakturama erkennt anscheinend keinen Browser mehr:

Some sites could not be found. See the error log for more detail.
Unable to read repository at [www.fakturama.org].
[www.fakturama.org] is not a valid repository location.
No repository found at [www.fakturama.org].

Kann mir jemand einen Tipp geben oder kann ich auch die neue Version "drüber" installieren, oder gehen dann meine Daten verloren?

Danke für eure schnelle Hilfe.
Re: Update unter Linux
27. September 2013 17:37
Hallo,

habe mein Problem gelöst. DEB-Paket runtergeladen, Doppelklick und dann hat das Ubuntu-Software-Center die aktuelle Version als Update erkannt und nach dem Bestätigungs-Klick installiert.

Alle Daten sind noch da. So kann ich (fast) problemlos weiterarbeiten.

Ein Problem das noch besteht, mit dem ich aber leben kann:

Mit dem Start als Admin habe ich Zugriff auf das Internet, als User nicht. Ging aber in vorherigen Versionen. Keine Ahnung was ich da "verbogen" habe.

Die Start-URL lässt sich aber bei beiden Herangehensweisen nicht ändern.
Domdom
Re: Update unter Linux
10. Dezember 2013 07:59
Hallo zusammen,

ich habe unter Ubuntu12.04LTS die Version 1.5.4 für meine Zwecke einwandfrei laufen.
Ich starte Fakturama ohne root-Rechte, kann machen, was grad auch immer anliegt, und ich bin auch sonst sehr zufrieden mit dem Programm!

Seit kurzem habe eine parallel Maschine laufen, wo Ubuntu13.10 drauf ist.
Hier habe ich 1.6.3 installiert.


Für beide Rechner gilt, dass meine Datenank auf einem Netzwerk- Laufwerk liegt.


Unter 12.04 kann ich wie bisher ganz normal arbeiten,
unter 13.10 muss ich Fakturama als root starten, damit ich überhaupt was machen kann.
Ohne root-Rechte kann ich nicht mal das Menu sehen, was normalerweise nach dem
Klicken auf "Datei" in der Menu-Leiste angezeigt...


Kann das damit zusammenhängen, dass 12.04 eine 64bit-Version ist,
und 13.10 eine 32bit-Version?


Vielen Dank!
Re: Update unter Linux
10. Dezember 2013 09:02
Hm, unter 13.10 scheint es leichte Probleme zu geben.
Da gab es schon diesen Eintrag im Forum.
Zum Menü gibt es hier auch schon etwas.
Ob eine Lösung für dich dabei ist, kann ich leider nicht sagen.
Domdom
Re: Update unter Linux
12. Dezember 2013 13:32
Hallo moped,

danke für den Hinweis mit dem Menü - der bei mir geholfen!
Aber Probleme mit Java oder so hab ich nicht... ?!?

Nach dem Script und der *.desktop-Datei ist alles wieder wie gewohnt!


mille gracie! :-)
Alex
Re: Update unter Linux
14. Mai 2014 16:37
Hallo an alle,

Ich habe lange mit Fakturama unter Ubuntu 12.04 in der Version 1.5.4 wundarbar gearbeitet.

Bei einer Neuinstallation von Ubuntu 14.04 versuche ich Fakturama in der letzte Version am laufen zu bringen, es will mir aber nicht gelingen. Das Program startet, fordert mich an ein Arbeitsverzeichnis wählen und anschlissend verschwindet ohne fehlermeldung. Bei einer Neustart wiederholt sich das ganze von vorn.

Gibt es schon Erfahrungen mit 14.04.?

Vieln Dank!
Re: Update unter Linux
15. Mai 2014 08:13
Keine Fehlermeldung? Auch nichts im Error.log?
Sieh dir mal diese Beschreibung an, vielleicht hilft dir das.
Alex
Re: Update unter Linux
15. Mai 2014 16:47
Es geht.
Großartig!
Re: Update unter Linux
30. September 2014 12:49
Eben habe ich versucht, innerhalb von Fakturama die ZUGFeRD Erweiterung zu installieren bzw. ein Update von 1.6.6 auf 1.6.6.1 durchzuführen. Beides ist gescheitert. Sowohl als normaler Nutzer als auch als root bekomme ich folgende Fehlermeldungen.

Beim Update:
Your original request has been modified.
  "Fakturama Core Feature" is already installed, so an update will be performed instead.
Cannot complete the install because of a conflicting dependency.
  Software being installed: Fakturama Core Feature 1.6.6.1 (com.sebulli.fakturama.core.feature.group 1.6.6.1)
  Software currently installed: Fakturama 1.6.6 (Fakturama.ID 1.6.6)
  Only one of the following can be installed at once: 
    Fakturama 1.6.6.1 (com.sebulli.fakturama 1.6.6.1)
    Fakturama 1.6.6 (com.sebulli.fakturama 1.6.6)
  Cannot satisfy dependency:
    From: Fakturama 1.6.6 (Fakturama.ID 1.6.6)
    To: com.sebulli.fakturama.core.feature.group [1.6.6]
  Cannot satisfy dependency:
    From: Fakturama Core Feature 1.6.6 (com.sebulli.fakturama.core.feature.group 1.6.6)
    To: com.sebulli.fakturama [1.6.6]
  Cannot satisfy dependency:
    From: Fakturama Core Feature 1.6.6.1 (com.sebulli.fakturama.core.feature.group 1.6.6.1)
    To: com.sebulli.fakturama [1.6.6.1]

Und bei der Installation:
An error occurred while collecting items to be installed
session context was: (profile=profile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Artifact not found: osgi.bundle,com.sebulli.fakturama.exporter.zugferd,1.6.6.201409282209.
[www.fakturama.org]
Artifact not found: osgi.bundle,com.sebulli.fakturama.zugferd,1.0.0.201409282209.
[www.fakturama.org]

Fakturama läuft hier unter Linux Mint Debian Edition (LMDE) 64Bit mit OpenJDK 1.7.0_21-b02

Gruß
3xhossa
Re: Update unter Linux
30. September 2014 13:03
Nachtrag: die aktuelle Version von ZUGFeRD lässt sich zwar nicht installieren, doch die Version 1.0.0.201409072318 wird problemlos installiert. Ein Update auf die aktuelle 1.0.0.201409282209 scheitert aber mit dem gleichen Fehler wie die direkte Installation.

Gruß
3xhossa
Re: Update unter Linux
30. September 2014 20:18
Die 1.6.6.1 ist auch gar nicht mehr online, ich check das gleich nochmal.

Viele Grüße,
Ralf.
Re: Update unter Linux
17. Januar 2016 13:07
Ich bekomme die Fehlermeldung:
"Cannot complete the request. This installation has not been configured properly for Software Updates. See error log for details."

Bisher habe ich auf meinen System frisch die 1.6.9 in 64bit installiert, sudo /usr/share/Fakturama/Fakturama ausgeführt und dann versucht über "Help / Check for Updates" zu aktualisieren....
Re: Update unter Linux
17. Januar 2016 17:22
Kannst Du bitte mal nachsehen, welche URL angesprochen wird? Das Update funktioniert normalerweise, ist aber trotzdem manchmal etwas widerspenstig...

Viele Grüße,
Ralf.
Re: Update unter Linux
17. Januar 2016 20:35
Oha... wie würde ich das denn tun? Sorry...
Re: Update unter Linux
17. Januar 2016 20:48
Einstellungen > Installieren/Aktualisieren > Websites mit verfügbarer Software

Viele Grüße,
Ralf.
Re: Update unter Linux
17. Januar 2016 21:12
Hätte ich mal genauer gesucht... Danke.

Dort stand tatsächlich garnichts. Ich hab jetzt mal [www.fakturama.info] und .org versucht, beide ändern nichts an der Fehlermeldung.
Re: Update unter Linux
17. Januar 2016 21:24
Und wenn Du dort [www.fakturama.info] einträgst?

Viele Grüße,
Ralf.
Re: Update unter Linux
17. Januar 2016 21:34
Also "[www.fakturama.info];? Führt zum gleichen Fehler...
Re: Update unter Linux
09. März 2016 12:37
Komisch. Ich hab das gerade nochmal gecheckt - funktioniert bei mir. Hab das ZUGFeRD-Plugin installiert. Update prüfen lief auch durch.



Viele Grüße,
Ralf.
Re: Update unter Linux
12. August 2016 21:40
Die Update Probleme habe ich auch.

Ist es nicht möglich, das Zugferd Plugin als Download zur Verfügung zu stellen? Denn das mit den Updates scheint ja nicht wirklich sauber zu klappen.
Re: Update unter Linux
19. August 2016 19:27
Ist hier eine Antwort zu erwarten?
Re: Update unter Linux
19. August 2016 20:48
Ich kann das nicht einfach als Download zur Verfügung stellen. Das erfordert noch ein bißchen Aufwand.

versuch mal [old.fakturama.info]

Viele Grüße,
Ralf.
Re: Update unter Linux
19. August 2016 21:00
[sourceforge.net]

Hatte ich vor kurzem im ZUGFeRD Thread in der Rubrik Fakturama 2 gepostet

------------------
Viele Grüße
Steffen
Re: Update unter Linux
20. August 2016 11:23
rheydenr schrieb:
-------------------------------------------------------
> Ich kann das nicht einfach als Download zur
> Verfügung stellen. Das erfordert noch ein
> bißchen Aufwand.
>
> versuch mal
> [old.fakturama.info]


Alles klar, das ist gut zu wissen. Dem Link kann ich nicht folgen, da fehlen mir die Zugriffe.
Sollte hilfe benötigt werden, dann sag gerne bescheid.
Re: Update unter Linux
20. August 2016 11:23
Miracolitag schrieb:
-------------------------------------------------------
> [sourceforge.net]
> elease/update1_6/
>
> Hatte ich vor kurzem im ZUGFeRD Thread in der
> Rubrik Fakturama 2 gepostet


Ah, danke Dir. Das schaue ich mir mal an.
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen